What's new

Audio Popping via Headphone Jack?

Ergo

New Member
I have a surface 3 (i7 512) I am experiencing the same popping sound some of you describe here.

I can replicate the POP whenever I want. If the system is completely silent for some seconds and I click on the volume control, right before the expected sound I get a loud POP.

I would say it has something to do with energy saving. It seems to me like the surface turns off the sound card until it's needed and turning it on causes the noise. Quite annoying because when I'm working and I get an email or instant message the pop sounds as loud as it possibly can in the speakers.

I have the surface connected to a hifi amp and when the amp volume is high and the volume control in the surface is low the pop that precedes the sound is 10 times louder than the sound. Has anyone died from a heart attack yet because of this issue?

I am downloading the new driver and will give it a go but I must say this issue is quite annoying.

By the way, this is my first post. I have been reading you since I got my S3 and you have been of great help so far. Thanks for that.
 

billmr

New Member
I had this same issue, I was playing music with wired headphones from bandcamp, and when I paused music I would get click click click click

if I were to change the volume it would go away for a few seconds

I tried all reverted to the prev driver and it it stopped the click click click, but there was a loud one when changing sources or when the audio was initialized.

with the latest realtek driver I had the same clicking issue.

When I stopped using waterfox and used IE instead the problem went away.
 

tony8154

Member
the popping noise issue lead me to this forum post.

I also had the popping issue and it was driving me nuts!

After following the driver update recommendation, the clipping is now gone. For those of you who still have it after updating the driver, maybe you should check to see if you downloaded the correct driver. If not, I guess you can always format and start from scratch.

It's unfortunate that you have to deal with such issues on such an expensive device that should come out perfect.

I also was dealing with a battery drainage issue which seemed to have resolved itself on its own.
 

tony8154

Member
ok the popping noise is not intermittent.

Sometimes it helps if I just mute the volume from the keyboard, but sometimes, even in mute, there is a constant popping/clipping sound.

It's a hit and miss and very annoying that even a reboot does not solve. :(
 

YKinase

New Member
I've tried everything except swapping devices. Still have the popping problem on headphones plugged directly into the jack. Unfortunately, I could not replicate it when I brought the SP3 into the Microsoft Store.
 

C Askes

New Member
I managed to resolve the popping by disabling the Intel Display Audio in Device Manager (not uninstalling it, just disabling it). I run a Pro 3, i7, 256g and the popping disappeared even after several reboots.

Device Mgr.PNG
 

razorblader

New Member
Got a 4/128 GB Surface Pro 3 recently and the tock tock tock noise in the headphones when not playing audio was extremely annoying to say the least. I installed this driver version: 64bit_Win7_Win8_Win81_Win10_R279

First install was with Comodo Virus scanner enabled and after the reboot following the driver install the problem was still present. Disabling the virus scanner and installing the driver for a second time - uninstall driver - reboot - install driver - reboot the problem is now gone and there's sublime silence where there was tock tock tock tock tock tock tock.....
 

smar

Member
The only way I managed to get rid of this problem was by:
  1. Uninstalling Realtek driver (making sure to tick the "Delete the driver software" option)
  2. Do a rescan of devices, following which it finds and installs "High Definition Audio Device".
This stops the popping noise on my SP3.

However, it seems as if after each update Windows reverts back to the Realtek drivers, and so I have to go through the process again. I did once see some powershell scripts floating around somewhere which prevents Windows auto-updating specific device drivers, which would probably help stop this constant reverting back to the Realtek drivers.
 

Crownie1

New Member
How I stop the popping noise on my SP3.

Go to:
Cortana > Notebook > Settings > [Turn on "Hey Cortana"]

and boom! fixed!
 

Members online

No members online now.
Top