What's new

Camera does not turn on during startup after update

Bandito

Active Member
This may not work for you, but this has fixed my Hello camera issues twice now. Once after the latest round of updates broke it and once after Microsoft Support broke it again by reinstalling the latest drivers.

1) Download the latest driver package with all of the Surface Book drivers in it from Microsoft. Download the .ZIP version and unzip it somewhere on your hard drive.

2) Go into Device Manager and under System Devices right-click on Surface Camera Windows Hello and select Uninstall. When the confirmation dialog comes up, check the box to remove the drivers from the system.

3) Once that completes, Scan for Hardware Changes. If the Surface Camera Windows Hello reinstalls itself, it will have done so with older drivers. Repeat step 2 to get rid of them too. Then do another Scan for Hardware Changes.

4) You should now have an Unknown Device with a yellow exclamation mark next to it. This is good and is what we need.

5) Go to where you unzipped the driver files, find the Drivers\Camera\WindowsHello folder and right-click on the SufaceCameraWindowsHello.inf file and select Install. The unknown device should disappear from Device Manager and the Surface Camera Windows Hello device should be back under System Devices. Your Windows Hello should now work every time as it did before.

I can't, obviously, promise that this will work for everyone, but it has consistently taken care of the problem for me.

YMMV

P.S.

Sorry. I didn't think to post the final working driver version. It is version 1.0.24.0 dated 10/2/2015.

Be aware that after install, when you look at the Properties on the General tab under Device Status it will state, "No drivers are installed for this device." This is apparently normal for this driver.
 

Oldwretch

New Member
Found that disabling Hibernation solved the problem. This also disables Fast Startup which appears to be the problem
 

miker55

New Member
I also had the 'Hell'o camera and 'detach screen' issues on my Surface Book. MS now have working patch process:

'Hello' stuck on 'Turning on camera' and 'Preparing security options'

Which states the following:
Step 1: As your Surface is powered on, press and hold the Power-button for 30 seconds.
Step 2: Press and hold the volume up-button and the power-button at the same time for at least 15 seconds, then release both.
The Surface logotype might flash on the screen while performing this step, but just keep both buttons pressed for the 15 seconds.
Step 3: Wait for about 10 seconds after you released the buttons.
Step 4: Start your Surface again by pressing and releasing the Power-button.


The UFEI is actually not a part of the troubleshooting. When you reach the UFEI setting, simply choose 'Exit' and 'Save & Restart' (you may only have the option to choose "Restart").
The 2-button shutdown is a troubleshooting step which searches the Surface for problems, and tries to automatically fix these, and it is really helpful if the problem is caused by drivers which are acting up or installed incorrectly.
Drivers are usually a reason for things that stop working suddenly, so you can use the 2-button shutdown in these cases.
This fixed it for me.
 

Gadget

New Member
None of the solutions in this thread fixed the camera issue for me, but the latest update appears to have fixed it. At least so far. Crossing my fingers it doesn't reoccur.
 
Search tags for this page

hello camera not turning on

my camera is not starting please open the camera

surface book camera does not turn on

surface book camera not turning on

surface book camera wont turn on
surface book stuck turning on camera

surface book turning on camera

surface book turning on camera stuck
surface pro 4 turning on camera stuck
windows could not turn on camera

Members online

No members online now.
Top