What's new

Can't activate the battery tray icon...


New Member
Hi there,

(in advance, my excuse for linguistic errors, I'm Dutch)
I recently bought two Surface 2, one for me and one for my mother.
On her device there is no prob's at all, but on my device, I'm missing the battery icon on the taskbar.
Even worse, I can't get any information on my battery at all!
In the power scheme I can't activate the battery section (gray text, non responding) while I'm logged in as administrator.
External apps from the store won't work either, they simply cant get the needed info from the device to work.
Yet, there IS an accu on my device (the standard one) and it IS working and I can use the device with no problems for several hours
(didn't tested for how long) without plugged into the wall. After googling, I found very little about this issue. The Microsoft site didn't
helped either. Some suggested I should turn the bluetooth on, to fix the problem - others believed it was the keyboard/cover thingy -
- either way, I tried and tried with several options, to get a battery indicator working.

It is very frustrating never knowing how much juice I've got left in my device, or even knowing when the battery is done charging.

Have any of you heard or experienced this strange problem?
If so, how did you fixed it or worked around it?

Edmund Bakker.
Last edited:


Did you try the little up arrow in the taskbar notification area on the desktop? Click on customize, and make sure the battery power indicator is turned on, "show icon and notifications". If it's a hardware problem, try a battery app from the microsoft store, to see if it will give you a percentage that will show on the Metro apps display. If an app won't show a percentage either, then it's probably an internal circuit problem with the surface.


New Member
Thanks for the reply :)
And yes, I always make sure that ALL icons in the system taskbar never hides (I kinda hate it when I can't see what's running)
So, that's not it :(


Staff member
I would do a factory reset. It would take about a half an hour to complete and see if it works as expected.


New Member
HURRAY!!!! :big smile:

@Jnjroach - your advice worked. I was thinking about that option myself, but I was afraid I would have to setup
the whole thing again (ms login, gmail, facebook(I know, I know! :rolleyes: ) and the photos and apps - etc etc.
But within the factory reset menu, there was an option to reset it while keeping all my apps and settings!
It too a while, about 15 minutes, and I'm not sure what it resetted. All apps and configurations seems to be like
it was before, all updates are still there - the only difference is that now the battery icon is back & working like a charm!

I'm very greatfull for the quick responses and advice from you lot - Thanks! :big smile:

Only one thing left for me to do : see if there is a fun/nice battery app I can find in the app store.

(a very happy) Edmund Bakker.


Staff member
No Battery Apps as the Power Management Subsystem is not available to any of the WinRT APIs


Well-Known Member
Glad you got this sorted.

I love the Netherlands, best place I've ever been to! Well done on your superb victory over Spain


New Member
haha thanks... I think?
I'm not a big football fan, I think that the whole fifa thing has nothing to do with sports whats so ever, and it is a but unfair to all the poor people in Brazil. I do like a good game, but with all that agression (like punching and biting) and unfair play and acting (our own mr. Robben, for example) on the grass is polluting the spirits of sports in general.

And on a side note: my Surface 2 is still working like a bee with ADHD and too much sugar :)
Buying that device is one of the best decision I've ever made :D