What's new

Chraging problems

Jinege

New Member
Chraging problems (total Freudian slip)

Hello, I have within the past month purchased a MS Surface. So far I have loved it, and my daughter also. However today I realized that when I plugged it in last night to charge, it didn't do so. I've tried to find solutions with just FAQs and online support, including this forum. I'm finding people with some of the same problems, but not completely like mine. So here's what's going on with mine:

1: the LED light isn't coming on when I attach it. (yes it's in correctly)
2: When I have the A/C attached, the screen brightens and dims erratically.
3: and this is when I knew something was definitely wrong, when the low battery warning came up, it would go away for a second and then come right back up.
4: the battery symbol switches from indicating charging--->the battery with the red "x" next to it, over and over.

I've messed with the connector (attached/unattached) over and over again, and every once in a while the LED light will come on for litteraly not even a second.

Anyone else with this problem or a solution to it? I sat on the phone with support for over an hour with no answer. Youtube provided nothing either, other than one with a guy messing with the connection for 30 seconds and then miraculously working.

Update: so it seems that I am getting a bit of charge even in it's messed up state. I was at four percent last I had the tablet on. When turning it on just a bit ago I was at 6. Took about 2 hours for 2%
 
Last edited:

Johntxk

New Member
I had the same problem. I tried every trick that has been posted online. The fix came when I bought a new Microsoft approved charger.
 
OP
J

Jinege

New Member
Well that would make sense to me also. But I had my girlfriend take my surface and the charger to her place last night. The charger worked on her surface just fine. Her charger didn't on mine. Has to be a problem with the tablet itself now I would assume
 
Search tags for this page

led isn't coming on surface charger

Members online

Top