What's new

Solved Dektop Flashes then fails to load


New Member
Hey there,

I'm running B10041 on a SP3. When I log in I get a flash of my desktop, and then just a blank screen. Something's' a little off I would say.

Does anyone else have this same problem?


Well-Known Member
Why don't you give us a little background like did your Surface ever boot correctly since you installed the new build. What was the last things you did before the problem started happening? Is the problem repeatable. Have you given your Surface the middle finger salute?


New Member
I applied the 10041 build over a fresh installation of Windows 8.1. I noticed that the installation took quite a long time which started me thinking something was up.

Since the installation completed, the system gets to the login screen, I CAN log in, however it goes to a blank desktop.

I've tried to simply go back to win 8.1 (fresh install) but the device won't seem to recognize the recovery image on the USB key... it just keeps looping through to the Blue recovery options.

Is there a way to just have the OS loaded on a USB key and then force a new installation. If there are instructions please let me know I can try that route.

In terms of the middle finger salute... :) yes! And I made sure it heard me too.... :)

Members online