What's new

Did my Surface die ?

PRS1978

New Member
Hi all,

So i tried to recover my sp4 after it crashed while updating. Now i am trying to boot with the recovery file downloaded from the microsoft site and booted from usb and started the recovery.
The problem is while recovering it stops at 46% and thats it. Nothing, it just turns of.

Anyone any ideas what to do ?

Prem
 

Aldec

Member
Had a similar problem a couple of weeks ago...when I tried installing the same M$ recovery as you it informed me on screen that there were no available drivers.....I ended up sending it back for reinstallation of the O/S.
Since then having given it a bit of thought the following would be worth trying if you can gain access on either the MS Pro 4 or any other computer with W10.
Open Control Panel, Security and Maintenance, Recovery, Create a Recovery Drive.
Most importantly.....UNTICK box Backup System Files....This has a very small footprint of KBs, don't forget to format USB to FAT32.
This should allow access to all recovery options that were originally installed including drivers.
Good luck.
 
OP
P

PRS1978

New Member
Well i contacted MS support and they said what Aldec had written, thank You by the way.
Now the SP4 won't reboot after installing Windows to finish the installation.
Tomorrow i have a free day, so i am going to begin from the start.

Will post my findings.

Bye
 

animateduser

New Member
I have many of these devices and have had to had a number factory reset, but I was unable to get things working so I took it to the MS Store. If you have an MS Store in your area, you might consider letting them do the hard lifting.
 

Plantje

Active Member
In the Netherlands we don't have Microsoft stores. On the other hand we DO have Microsoft support which is really good! If you need any help there, let me know!
 
OP
P

PRS1978

New Member
Like Plantje said we do not have MS stores in the Netherlands.
I contacted MS support and got my SP4 running again. During the installation of win 10 remove the keyboard cover as soon as you can, otherwise the installation will fail.

Only issue remaining is an error with the power supply, its connected but does not charge and only with the power supply connected the SP4 turns on. I am going to try the solutions posted on the MS support site when I am home.
 

Members online

No members online now.
Top