What's new

Reloading OS on SP6 - No Recover From A Drive Option


New Member
I have come looking for help on this strange issue of trying to reload the OS on the Surface Pro 6. I think I am going crazy lol! I am really happy there is this forum for Surface Pro so kudos to the moderators and creators!

Firstly, there is 5 images that can be downloaded:

Obviously, I would like to load the 20H2 version a.k.a. SurfacePro6_BMR_16_12.412.0.

I've watched lots of videos and read lots of guides to creating a recovery key but I just can't get a key with the recover from a drive option.

(I don't know why they can't just make an ISO image to burn to USB or CD)

So the general idea is:

1. I use a Windows 10 computer to create a recovery drive and uncheck backup system files.
2. Copy the extracted contents of SurfacePro6_BMR_16_12.412.0 to the key overwriting any files.
3. Boot the key and select Recover from a drive and move on with my life.

I've tried all kinds of different versions of W10 and W11 and every time I boot a recovery drive there is no recover from a drive option. Is one of the files being copied over causing this?





I've tried different USB keys and that's not working either. Maybe someone know a particular model of USB that works but the one I have are not working?

I though I would try Acronis PE with drivers injected from the Surface Pro 6 Drivers Pack to load an image but that's not working either (no keyboard or mouse or touchscreen.) Update: My Acronis WinPE with injected drivers is booting and the touchscreen is working but it won't see my hard drive connected to my USB hub.

I though I would try to inject the drivers from the Surface Pro 6 Drivers Pack after converting it from msi file but that's not working either.

Maybe if someone had a recovery drive that's working they could take an image of that and upload it?

I would just install W10 normally but the drivers are missing for the touchscreen and keyboard and mouse are not working so that's not working either.

Now I've seen this issue in a lot of posts on other sites but I haven't been able to find the solution.

Sorry for the long post but thanks for your help and have a great day! :)