What's new

Dock Problems with Multiple Displays

td0071

New Member
Hi,

I'm using the new dock with a surface pro 4 and two displays. First time I plugged them all in it was great. All working well, I could extend the display from the surface pro across my two monitors with no problem.

Then, after a shutdown it stopped working.

Three displays are identified but only two (the surface pro and a 1080p 60hx monitor) display an image. The third monitor is recognised on the surface display properties but displays no image.

If I unplug that monitor the other works fine.

I am all up to date with windows etc. and getting very frustrated. I read that sometimes using an active display port to HDMI adapter helps but to no avail. I can still get it to display but not all at the same time on the dock.

I even trued using my Wireless Display adapter but that stops working as soon as the dock is connected.

Any suggestions? I have searched all the forums on the topic but found no answers. Is it really that unreliable?
 

29671

New Member
I just upgraded from the Surface Pro 4 to the 2017 Surface and I am having this exact issue.

With the Surface Pro 4 my dock worked great with dual monitors. Now with the new Surface I can only get one monitor to activate. The other one keeps turning from active to standby.

Appreciate help on this Microsoft!!

Hi,

I'm using the new dock with a surface pro 4 and two displays. First time I plugged them all in it was great. All working well, I could extend the display from the surface pro across my two monitors with no problem.

Then, after a shutdown it stopped working.

Three displays are identified but only two (the surface pro and a 1080p 60hx monitor) display an image. The third monitor is recognised on the surface display properties but displays no image.

If I unplug that monitor the other works fine.

I am all up to date with windows etc. and getting very frustrated. I read that sometimes using an active display port to HDMI adapter helps but to no avail. I can still get it to display but not all at the same time on the dock.

I even trued using my Wireless Display adapter but that stops working as soon as the dock is connected.

Any suggestions? I have searched all the forums on the topic but found no answers. Is it really that unreliable?
 
Search tags for this page

azs

news

Top