What's new

High CPU usage, Fan Blasting (Service Host?)

leeshor

Well-Known Member
I have had my fan on almost constantly over the past few weeks. My cpu usage remains low, around 10% or so. If I just have the desktop up, the fan turns off after a few minutes. Open up an app or web browser and it ramps back up. It is loud enough that my wife comments about it while we are watching TV. I'd love some steps on how to troubleshoot this.

I have an i5 / 128gb running Win 10, without the touch keyboard. I am using an incipio feather case, could that cause more heat to be retained? Software-wise, I am using bitdefender free for AV. I also installed the 9/29 firmware update and I am up to date on my patches.
Bitdefender, based on other posts on the forum, has been known to be a problem for high resource usage.
 

zhenya

Active Member
I have had my fan on almost constantly over the past few weeks. My cpu usage remains low, around 10% or so. If I just have the desktop up, the fan turns off after a few minutes. Open up an app or web browser and it ramps back up. It is loud enough that my wife comments about it while we are watching TV. I'd love some steps on how to troubleshoot this.

I have an i5 / 128gb running Win 10, without the touch keyboard. I am using an incipio feather case, could that cause more heat to be retained? Software-wise, I am using bitdefender free for AV. I also installed the 9/29 firmware update and I am up to date on my patches.
What speed is the processor showing when at 10%?

I would definitely think the case will add to the problems as it's effectively an insulating blanket.

I have just come to accept that the fan will run audibly on my SP3 most of the time. I would consider the Core-M model for my next purchase if they offered at least 256/8GB paired with it.
 

Alershka

New Member
What speed is the processor showing when at 10%?

I would definitely think the case will add to the problems as it's effectively an insulating blanket.

I have just come to accept that the fan will run audibly on my SP3 most of the time. I would consider the Core-M model for my next purchase if they offered at least 256/8GB paired with it.
I had to wait until I got home to check cpu speeds. Once things settled down utilization was around 10% and cpu speed was about 1ghz with just Reddit passport and chrome open. Fan was mostly off but will try uninstalling bitdefender and removing case to see if situation improves overall.
 
OP
K

kozak79

Active Member
You know, it didn't give a breakdown of each task under Service Host.

But I think I fixed it. Been googling for a long time and found on another forum that it might be the ProgramDataUpdater. Setting it to "1 Minute" seems to have resolved it for now. I'll see how it goes.

View attachment 6889
After a couple of weeks I can say that my High CPU / Heat issue is fixed. Using the fix above my system is running smoothly and cool.
 
Search tags for this page
base filtering engine high cpu
coremessaging cpu
coremessaging service
diagnostic policy service high cpu
dps diagnostic policy service cpu
dps diagnostic policy service high ccpu usage

dps diagnostic policy service high cpu

dps service local service no network

surface book service host high cpu

wdisystemhost diagnostic system host cpu

Members online

No members online now.
Top