What's new

I have to use startup repair on restarts!


Yesterday my Surface went ape when I took of the docking contact. I only saw the mouse pointer in the middle. I could move it, but nothing else. I tried to connect it again, and it did connect, but then I saw nothing but the mouse pointer in the middle of the external screen. So I pressed the power button for 16 seconds (or so), and it turned off. When I fired it up again, I first saw the choice between my two WInows 10 installations, and I chose the right one. Then it was stuck at the Surface logo for five minutes or so. Gave up and tried the other installation. Same thing there. So I put in the Windows 10 installation USB I have and ran the startup repair there (after typing in the gazillion numbers in the Bitlocker code). After a run it said it couldn't repair the thing, so I tried to go to WIndows 10. Luckily it restarted and fired up. Today it happened again, but not in the same way. This time I turned on the wifi after docking (I often tur that off while docked because I have wired LAN in it, and sometimes a computer will still use wifi even with LAN plugged in), and it wouldn't connect. So I did a restart. And the same thing happened as after the crash. Windows 10 internal startup repair just stood on "initializing" (or something like that), but using the USB gave me the same result, so I'm up and running. usually I don't restart my Surface for days and weeks, and now I'm scared to do it at all! Can this be the side effect of the lastest update? I haven't done anything else to the computer.