What's new

Installing .Net 3 and prior?


New Member
I have a number of applications including battery bar pro I'd like to install which require older .net libraries. I should be able to add them by selecting .Net3 in the windows add/remove features. This always fails with a network timeout... googling shows lots of people with the same problem on win 8.1 and a suggestion to install from the .iso with the dsim utility (see How to enable .NET Framework 3.0 and 2.0 manually in Windows 8.1 RTM). Since the Pro 2 doesn't come with any media, I tried pulling the MSDN 8.1 x64 iso but that also fails using dsim. I see from the posts on this board that many of you have battery bar pro working which must mean you've been able to solve this problem.... how? Thanks, Jon


New Member
*Edited* Broken for me too. It used to work on Windows 8 Pro, but not in Windows 8.1.

Last edited:


Active Member
All of the programs I've installed that needed .NET libs popped up a window during install that gave me the option to install .NET which completed normally.


For me it worked, I just didn't went with the CMD but just windows + X and to program and features and then turned the feature on. My program needed .NET 2.x and it didn't start without is and afterwards it did.


New Member
From my google searches, there appears to be a common problem with the BITS service not functioning properly and breaking many things. I managed to get this to work by running the GUI based .net3 add immediately after a boot before BITS had a chance to get flakey.