What's new

java not working in IE 10

Arizona Willie

Active Member
All of a sudden, starting this morning == everything was fine yesterday, java will not work in IE10.
Works fine in Chrome and Firefox.

Tried both metro and normal versions of IE 10.

I get a HUGE popup that says " Javascript must be enabled on your browser to view this site. " but javascript IS enabled in the add-ons.
Also, there is an X in the upper right corner of this popup that WILL NOT shut down the popup. I have to close IE 10 to get rid of it.

I looks like this version of IE10 is only a 32 bit version but I installed a 64 bit version of Windows 8. How in the heck did I not get a 64 bit version of IE10?
Looking in the add-ons there are both 32 and 64 bit versions of the add-ons. Many add-ons have both.

But only the 32 bit version appear to be working.

Was there some kind of an update yesterday that hosed IE10?

I didn't do anything to cause this that I can remember.
Usually both 32 and 64 bit IE's are installed with windows. I also know that java does not work in the metro app. I would go ahead and reinstall java if I were you
Well I downloaded Java (32 bit ) and re-installed but it made no difference.

Reading around various places they say the 64 bit version should say 64 bit version, but I go into c:/programs/internet explorer and run the .exe file there but it does NOT say 64 bit version in the About Internet Explorer. The only difference I can see between the version in Programs and Prgrams(x86) is about 4 megabytes bigger in the Programs directory.

But when I run either one, all my bookmarks and favorites are there.

The version number in the About Explorer is the same for both versions!!

The real puzzler is that java is working fine in other browsers, just not in IE10.

But actually, I'm in the wrong place :) IE 10 works fine on my Surface ... the problem is on my desktop. I've just got so used to coming here looking for answers I didn't even think about which machine the problem was on.
To add more to the puzzle, my Metro IE icon is running the desktop version NOT the Metro version. All the IE browsers look the same and show the same version numbers when i run them. And the Metro interface was quite different. Can't seem to get it to run. If I go into the Programs directory and click the Internet Explorer.exe file I get the same version I get when I click on the IE icon on the regular desktop and the version numbers are all the same. Can't seem to get the Metro version of IE to run at all.
It sounds like you disabled Modern IE. You most likely are trying to open pinned sites and have checked the open in desktop option. Possibly even deleted the actual Modern IE app tile. See this thread to allow links to open in Modern IE http://www.surfaceforums.net/forum/.../3970-get-mail-app-open-links-desktop-ie.html. To get the Modern IE tile back (if deleted) you will need to install it through the store.

Edit: This might help you visualize it http://www.howtogeek.com/108128/how...ro-web-bookmarks-open-in-the-desktop-browser/.
What version IE are you running? I'm running 10.0.9200.16484 and I don't see anything about 64bit under my about either. My Java works fine. I am running 32bit Java tho
J5150P ... I just went to that howtogeek.com and I < think > that is part of the answer. I tried to do what it said and opened IE and went to Internet Tools / programs and it IS set to open links in desktop Internet Explorer.

Unfortunately, it is dimmed and won't let me change it.

Dunno what to do now.
prscarp: it appears my IE10 has developed multiple problems. First one was that I started getting message that java wasn't working and then I discovered that Metro IE 10 isn't working either.
I have a sneaking suspicion the problems are related. Right now IE10 is set to open all tiles in desktop IE10 and that seems to be the reason I can't run Metro IE10.

I don't know if Metro IE10 is in a different location or has a different program name. If it is / does I might be able to run it directly by clicking on it in Explorer, but clicking on the .exe file for both 32 bit and 64 bit is running the same program even though I am not clicking on an icon but rather on the program directly in Explorer.

But that is probably technically an Icon.

< sigh > You gotta love computers.
Oh, I just recalled I think that when you check that box it does uninstall Modern IE by default leaving you only the desktop. Go into the app store and install Modern IE again.

Store>swipe up from bottom>your apps>all apps
If I set IE10 as the default browser then the icon for METRO IE10 works.

If I set Chrome as the default browser then in Internet Options the box to open files in desktop Internet Explorer is checked and can’t be unchecked and the icon for Metro IE 10 runs the desktop version because that box was checked. So if another browser is the default I can’t run Metro IE10.

Firefox is not installed on the desktop computer so I can’t check it.

I only have Chrome and IE installed for browsers.

This looks like Microsoft screwing with other companies browsers.

If it was happening to other people I would be sure of it, but I’m the only one so there is some setting somewhere on my computer that is hosed or there are cross-linked registry entries or something like that I think.

As for the problem with the pop-up telling me java needs to be installed, I have discovered that only happens on ONE site ( that I know of so far ) and ONLY when I open a link on that site.

I can access the main page with no problem.

It is a newspaper site and if I click on an article I get the pop-up. I get the pop-up both when I click on the article to open it directly and when I right click and open it in a new tab.

Only in IE10 either Metro or destop version makes no difference.

Also there is another very teeny pop-up at the bottom of the page that tells me an add-on failed to run BUT IT DOESN’T TELL ME WHICH ONE!

Talk about useless :(

Well, at least I’m on the trail of the problem.


PS One other problem with IE 10. If I go to C:/PROGRAMS/INTERNET EXPLORER and click iexplorer.exe it runs the 32 bit IE10 NOT the 64 bit which should run from that location.

No matter which one I go to either in Programs or Programs(x86) I get the SAME version of IE10.

That ain't right either.
Last edited: