What's new

Legacy apps - can't run a particular one on surface pro, but works fine on laptop...

Northern

New Member
I've encountered an issue with running a particular DOS based application on my Surface Pro. Although I have set the properties of the application to run in Windows XP compatibility mode, and have allowed it to Run As Administrator, the Surface Pro returns the following error:
"Windows cannot find 'C:\Service.exe'. Make sure you typed the name correctly, and then try again."

Regardless of where I have saved the file, the same error occurs. I run the application by right-clicking on it and running it as administrator.
If I do not right-click and run as administrator, Surface Pro says,"This app can't run on your PC. To find a version...etc..."

Problem is, I have this exact same application running successfully on my Windows 8 Pro laptop - a Dell XPS M1330.

Any suggestions or thoughts?

Thanks all!
 

jnjroach

Administrator
Staff member
A 64bit OS is unable to run a 16bit DOS application, you would need a 32bit OS to run it. I would suggest running in a Virtual Machine through enabling the Hyper-V role on the pro, unless the DOS app needs direct access to hardware which I guess would prove even more difficult as none of the Pro hardware would be supported in DOS.

Is there a 32bit equivalent or upgrade to the application in question?
 
OP
N

Northern

New Member
Thanks for the reply Jeff,

Unfortunately this application is used to connect to a medical device - essentially robotics. I connect via USB to 9 pin connector and then to a 25 pin connector (I think its 25 pin...). No updated program is available.

I did some more digging and read about DOSbox. I will try that to see what happens as this link:
Running DOS Programs Under Windows 8 - Dos - Windows 8
seems to indicate this as a possibility. That the program works on my 32 bit machine seems like a good start at least.

The whole point to this is that I'm wanting to move completely to working only with the surface Pro. With this single exception, I am almost entirely paper free and using only the Surface Pro. Thanks Microsoft! Just need this one more app....
Once I've tried DOSbox, I will update here with the results.
 
OP
N

Northern

New Member
OK. So using DOSBox did not work as apparently, "Many USB serial ports do not support a 5 bits per byte configuration...". I have no idea what that means, but I lifted that little phrase from this site:
DOSBox DOS Emulator / Patches / #249 USB Serial work-around
which apparently has a fix for it. Problem is, I have no idea how to apply the suggested fix as there appears to be some recompiling necessary using MinGW or similar program. If anyone out there knows what to do, can do it, and can provide the recompiled file(s) I know your advice and/or work would be hugely appreciated. The problem described by 'Guly' on the sourceforge forum is virtually identical to what I am trying to do.

Any and all help is welcomed!
 

oion

Well-Known Member
That's really too bad (yikes, medical robotics, sounds important!). For much more technical help, though, I would recommend posting under the Surface or Win8 section of the XDA Developers forums (on my phone right now so not easy to link, but easily found via search). They're the people who did the Windows RT jailbreak, after all.
 
Search tags for this page
can i run filemaker pro on a microsoft surface
can surface pro 3 run dos applications
can you use turbotax on a surface pro
does turbotax run on surface pro?
run as administrator windows surface 2 not working
running dos on a surface pro
surface pro 3 legacy apps xp
surface pro legacy apps
turbotax for surface rt

will turbotax run on surface

Members online

No members online now.
Top