What's new

Mouse / Pointer click issues


New Member
Hello all,

I have a new Surface Pro 128 and I love it! I have, however, ran into an issue that I'm hoping to find a solution for. When in the desktop, clicking on the trackpad (I have the Type version), or using a Logitech M505 causes a strange anomaly. The cursor automagically moves to the upper left part of the screen about 1.5" from the top and left side. This only happens when I click and hold the left button and then move the mouse or my finger on the trackpad. It's like the pointer is being drawn to that part of the screen as a zero crossing. Once there, I can move the cursor with the mouse or with my finger to where I need it to go, but if I continue to hold the button and let go, it is still pulled back there. This causes issues in an programs (such as Ableton Live) where by holding the button and moving the mouse up and down or left and right it changes a value. With my issue, the moment I move my cursor, the value is either maxed out or brought to zero with no ability to adjust in the middle. Anyone else have this issue? :confused::confused:


Updated my system last night and retried some of the programs having the issue. The problem is still occurring. When I click on an object (with either the mouse or the typepad) the mouse cursor disappears and reappears about 2" to the left and 1" above the click point. This happens with both the left and right clicks. This issue is happening in multiple programs from multiple companies from Ableton Live 9 to Second Life. Still only noticing this issue in Desktop mode.
Last edited:
Alright, it looks like the issue has been solved. Here's what I did:

After purchasing a mini HDMI connector and hooking my Surface up to my LED monitor, I opened up the same programs under the desktop. The same issue existed. I then decided to make the external monitor my primary display and started tweaking the display options because even though the Surface was set for 1920x1080 it still looked oversized on my screen. I changed the text size from Large (default) to Medium. I reopened Live 9 and noticed that the screen real estate was much better than before. I randomly tried turning some knobs and voila!! I could now change the parameters without having to use the arrow keys. This worked with my USB mouse as well as the Surface Typepad's trackpad. Who knew that text size could cause this problem?
Hmm..the pen does the same thing randomly. I never thought the text size would effect that. Will try that fix out next time it occurs on tablet itself.