What's new

Type cover question / problem

Arizona Willie

Active Member
This morning I had the type cover attached and tried to right click on the desktop to get to where I could change the brightness.

NOTHING happens when I right click. No menu comes up ... nothing.

Is the type cover broke?

Also, how the heck do you get the Surface to scroll up and down with the type cover with no mouse, other than touch scrolling?

I tried dragging the cursor holding < shift > and < alt > and < cntrl > and nothing worked. Without a mouse I can only scroll up and down by using my fingers on the screen.
Observed this trying to use the browser(s). Doesn't even work in IE10.

Ooops .. oh yeah, I can also click on the scroll bar below or above it's current position with the left mouse button and that will move the screen. But not the best method.

-----------

NEVERMIND :(

When I push on the trackpad I hear clicks like clicking mouse buttons and I was trying to use it like a mouse ... by clicking the buttons.
Just discovered the two finger drag on the track pad for scrolling.

Aaarrrrrgggghhh. Geesh I have a severe case of the dummazz.

Also I discovered the right clicking DOES work but I have to tap the touchpad near the front edge. Tapping up toward the keys does NOT work even though I hear it click.

As you can tell, I never used touch pads on a laptop before. Always used a mouse.
 
Last edited:

bertopl

Active Member
yeah, right-clicking AND two finger scrolling are hit or miss on mine too. I actually wish they would incorporate what the MacBooks do with their trackpads since I'm so used to them on my MacBook Air. when you click and drag on a MacBook, you can actually lift your finger off the trackpad for a moment to readjust your finger position on the trackpad and continue dragging. it's pretty frustrating the way dragging works on the type cover trackpad especially since the trackpad is so small.
 
Search tags for this page
how to right click on surface type cover
surface pro 3 type cover not scrolling
surface pro 3 type cover problems

surface pro type cover problem

surface pro type cover problems

surface pro type cover right click
surface type cover how scroll
surface type right click
type cover problem
type cover problems

Members online

No members online now.
Top