What's new

Pen doesn't hold connection with Surface Pro 3


New Member
Alright, so basically here is what happens: I connect the pen for the first time (the bluetooth function) and it works for a while (5 minutes tops) After this time period, the bluetooth has disconnected and as a result the "Magic" button no longer functions, but writing, erasing, and using the "right click button" still works. I've tried to delete and reinstall pen drivers, that hasn't worked. Reconnecting is even worse, since my Surface Pro 3 only shows that it is connected for a split second and then goes back to paired. I've also power cycled the Pro 3, and that hasn't helped. The closest I've come to fixing it was removing the battery from the pen, and then putting it back in, but then we go back to the same issue of only staying connected for about five minutes. At this point I don't know what to do.


Staff member
Here is something to check: 2.4 GHz interference.

Find out if the same thing happens at a different venue (location). Since BlueTooth uses the same bands as WiFi, congested areas can be a problem.

Others on this forum have solved a unilateral problem by changing their router channel or rearranging their work environment a bit.

Eliminate this as a possibility, then we can take next steps.