What's new

2 separate pens won't ink on SP3


New Member
Is what it sounds like. A few weeks ago, my Surface Pro 3 stopped recording input from the surface pen from the pen tip at all. No tracking, no ink, basically records no input from the pen tip, generally, on-screen as well as within programs including Paint 3D and OneNote. However, the pen itself was still connected via Bluetooth and the pen top button (default pen) functioned; the pen was able to pair and unpair with the SP3. Tried to reset bluetooth several times without improvement in problem. No specific changes to computer, no new installs or program changes.

SO I assumed it was some type of pen malfunction that for some reason the tip wasn't registering any contact. Ordered new AAAA batteries and replaced the one in the pen. No luck. So I bought a new SP3 pen, supposedly unused, and tried it.

No luck. Was able to pair the pen with the SP3, but again the pen tip was not being registered. So this led me to think perhaps it's the driver or something firm-/soft-ware related. So I disabled and re-enabled the pen driver under Human Interface Devices, then made sure the driver was up to date manually. Is presently enabld with no problems listed under general device driver comments. Currently running driver version Tried two-button shutdown, though I'm not sure if I did that right tbh.

No success there, so I reset Windows, keeping all personal files. Still no luck. As before, able to pair with the pen and the top button works with blinking light, but no inking or tracking. Finger input works perfectly fine. Tried recalibrating touch input, didn't change pen problems. Downloaded the Surface Diagnostic Toolkit and got an all-clear. Downloaded Surface Pro 3 firmware tool from Windows, installed that, didn't change anything. Windows is up to date, currently running Win10 build 1709.

So that's where I'm at...I'm not sure where else to go. Maybe full system restore to before the pen stopped working? I dunno. Device is out of warranty. Any help would be really appreciated. Thanks for reading.

About my computer
Surface Pro 3
128Gb SSD
i5-4300 CPU
Windows 10 Version 1709, OS build 16299.248
Pen driver version
Pen settings driver version 12.0.303.1
Both pens are the original SP3 pens from what I can tell

(Sorry if this should be under SP3 general)


New Member
My pen, even on fresh batteries (all 3) is working only from time to time. Don't know what's causing this, so I just stopped using it.


Staff member
Hi, @mindlessnerd,

Sorry you're having trouble. I see you are on Version 1709 (September, 2017). You should update Windows 10 to Version 1903 (March, 2019) so that all your drivers can also be updated.

Let's see if that fixes you up.
Let us know.