What's new

Red Boot Screen


New Member
Try this:

1. Press and hold the Volume Up button.
2. Press the Power Button to turn the Surface Pro on.
3. Continue to hold the buttons until the Surface loads the UEFI screen.
4. You will enter the UEFI
5. Touch “Install Default Secure Boot Keys”
6. Touch “Yes” to load default secure variables
7. Look at “Secure Boot” and confirm it is enabled.
7. Touch Exit Setup.
8. Touch “Yes” to save configuration changes and restart the Surface


Thank you so much for the exact procedure. I was getting nuts not being able to enter the bios/UEFI screen, because I never actually held down Volume Up before hitting the Power Button...


Well-Known Member
Microsoft evidentally knows about the problem and says it can' be fixed, I would be hesitent to do a work around as you have found. I would do as Microsft says and return it. Who knows what else may be lerkging inside those computers that can cause a different problem to crop up later.


Well-Known Member
No. He said he googled and that was the end of it. I'm sure either search engine would have worked as well, but google seems to have become part of the common language. I google by voice on my iPhone quite a lot and it works very well. Fast and efficient, usually.

Just started using this as I had to install Chrome and it's pretty damn good! Much more useful than Siri.


New Member
This happens to me as well.
I just got my surface pro 2 yesterday.
Love it.
I have set up a bunch of stuff and I wanted to use Clonezilla to image the C drive.
I made a bootable Clonzilla USB drive and tried to boot from it.
Got an error message that it was not valid to boot from the USB because of the "secure boot control"
I went into the UEFI Firmware settings and disabled Secure Boot Control.
It now booted with a red screen exactly like the picture above in the forums.
I guess that's OK because it's telling you that the Secure Boot Control is disabled.
After that it booted into Clonezilla from the USB drive.
(By the way Clonezilla locked up because it couldn't use the Surface Type Keyboard.
It did boot but without a keyboard or mouse I couldn't use it. That's another issue.)
I then went back to the UEFI Firmware settings and enabled "Secure Boot Control" , but the machine still boots with the Red Boot Screen.
I think it's a bug.
Here is my theory:
When you disable the "Secure Boot Control" it sets a bit in the firmware that causes the Red Boot Screen.
When you enable the "Secure Boot Control" they forgot to put in the code to reset that bit.
If my theory is right then it won't matter if you restore factory settings because that won't effect the firmware and the bit that makes it Red Boot.
Anyway the system still seems to run fine and I love it.


New Member
When you reenable secure boot you have to install the security keys as well. When you disable secureboot it removes the keys from the system. Just enable it and click "Install security keys" right below and reboot. It will be back to a black screen.


New Member
Disabled the UEFI (Secure Boot) function in the BIOS. If you enter the BIOS as detailed here BIOS, then re-enable the Secure Boot option and reinstall the Secure Boot Keys. The screen should then be back to normal.


New Member
Hey guys!

Great job on finding a solution for the red screen! Unfortunately my SP2 still has an issue.

I followed the steps after updating the new firmware and it removed the red boot screen.
I also checked via PowerShell to make sure that SecureBoot was enabled.

Every time I boot up my PC, it takes me to the UEFI screen. As SecureBoot and the Default keys have been installed I no longer see the red background HOWEVER It still takes me to the UEFI configuration.
This happens every time I boot.

If I'm lucky (maybe once every 15-20 boots), my SP2 will continue to load into windows and functions as normal.

Temp solution:

Would be great if anyone had any ideas or thoughts on the matter..