What's new

SP3 Build 10074 (Slow ring) Brightness control unresponsive


New Member
Issue: Brightness control is unresponsive, I have used all the methods I could find to try and adjust the brightness but the screen remains fixed at maximum. I tried the Fn + Del shortcut, the battery icon pop-up, and the settings menu. When trying the keyboard short cut the onscreen brightness bar shows up and slides up and down, but there is no effect on the actual brightness level.

Build History: This is a new install of the build from the ISO file. I have set up a dual boot on a new partition of the C drive.

After installation I also ran the Surface Platform Installer from Microsoft's driver download page. I have a suspicion that the issue may come from a driver problem, especially after noting that the active driver for the display adapter was "Microsoft Basic Display Adapter", and the driver for the Monitor is "Generic pip Monitor", however I am just not familiar enough with this hard ware to know if these are the appropriate drivers, or if that would even effect my ability to adjust the screen brightness. Honestly it may be a new bug just inherent to the preview build, but it seems from looking around that most are not having this problem.

Updates: Windows update is current and shows no pending updates. I Successfully installed the following updates after installation of the build:

Security Update: KB3051768
Security Update: KB3046002
Security Update:KB3061876
Windows Update: KB3062095
Windows Update: KB3061161
Windows Update: KB3061162
Also successfully installed the System Firmware Update - 5/14/2015

I would appreciate any pointers you might have, for the mean time i'll just run off of the 8.1 partition because I use the tablet mostly in a mobile setting, and battery life is a high priority. Also please let me know if I can provide any more useful details.

Many Thanks

Your Registry might need a little kick in the ports:
Try this:



Thanks for the suggestion, I would be happy to try it, but registry editing is not something I have a lot of experience with.

I have navigated to location in the registry that you mention, but I don't find fields with the names you mention. Ill attach a screenshot for your reference, if you have time to give more detailed instructions I would appreciate it,


  • Screenshot (1).png
    Screenshot (1).png
    172.1 KB · Views: 616
You are likely missing the correct drivers.
Your Build installation needs a Refresh (Settings, Update & Security, Recovery, Refresh)
Your screen was not properly identified the first time around.
Ironically, I tried downloading the driver pack from Microsoft and manually installing the Display drivers using the .inf files, when that didn't fix it, then I did an OS Refresh, no change... and then a fresh OS Reinstall to try and fix the problem, each time I get stuck with that "Microsoft Basic Display Adapter" rather than the Intel Drivers

I'm not sure the "Microsoft Basic Display Adapter" is the issue. Seems to be something else. Do Brightness functions work okay with Windows 8.1 ?
Yep, works fine on the 8.1 partition, and honestly I haven't had any other trouble with Win 10.

The brightness bar shows up when I hit FN + Del and I can move it up and down fine, it just has no effect on the screen brightness.
The brightness bar shows up when I hit FN + Del and I can move it up and down fine, it just has no effect on the screen brightness.

See if auto-brightness is on. If so, it may be overriding the settings.