What's new

SP3 Wakes Itself Up

bluegrass

Well-Known Member
This was happening to me. For some reason mine would wake up and the camera would be turned on. I turned off the ability to swipe down on the lock screen and the problem stopped. Something was triggering a "swipe down" and waking it up to the camera.

Not sure if that will help you but I thought I'd throw it out there.


John

I looked to see where you could control swipe down on lock screen and didn't see any. I come out of sleep by just pressing the Enter button. If I swipe down, it turns the camera on and displays what the camera sees and shows a button to press to unlock.
 

foghat

Member
This has happened to me twice at work. I am thinking maybe my mouse got bumped or something. I dunno. It is weird. If it keeps happening, may have to look into it a little more.
 
fwiw, when I want to make sure my sp3 wont wake up, I do a shutdown. only takes a few more seconds to get back to work and everything starts with a fresh slate, including WiFi. still light years faster than starting my laptop
 

palmor

New Member
I looked to see where you could control swipe down on lock screen and didn't see any. I come out of sleep by just pressing the Enter button. If I swipe down, it turns the camera on and displays what the camera sees and shows a button to press to unlock.

If you swipe and go to settings/change PC settings/PC and Devices/lock screen there is a section at the bottom for camera. Turn the "swipe down on lock screen to use camera" to off.
 

yonghong

Member
Hey guys thanks for all the feedback.

I had already checked Hyper-V and as ctitanic pointed out, it was unchecked by default. I'm not using a Targus docking station, just the new Surface docking station. As stated before though, the problem persists both when docked and undocked so that can't be the problem.

And I'd rather not disable the Bluetooth considering that's how the surface pro pen works--a function I use from time to time.

I looked at the scheduled tasks and nothing there is enabled to wake my device except for "manual windows update" which has a last run date of "never" and something else I can't recall that has a last run date of days ago (the problem has occurred as early as 30 minutes ago). Both of those options are grayed out and seemingly cannot be changed.

What's strange is it seems as if I can wake the SP3 (within the 5 minute timespan before it wakes itself up) with my mouse and typecover despite having no devices enabled to wake it up. I double checked this through command prompt and yea, not a single device is enabled. However, now the command prompt's last wake entry gives the following response:

Wake history count - 1
Wake history [0]
Wake source count - 0

What the hell is going on? :(
It's definitely mouse's problem, my BT MOUSE always wake up SP3 ,so before I put sp3 sleep, I have to turn off BT mouse first.
 
OP
S

Sean

New Member
Hey, everyone! So it's been a couple days now and the problem has seemed to have corrected itself. I didn't even start up the device for those couple days and don't recall installing any updates other than a Windows Defender Definition which doesn't mean much in this case.

I've put the device to sleep under all previous conditions (with/without attachments, docked/unlocked) and so far so good! Granted I only let it sleep for about 6-8 minutes each time--recalling that it took 5 minutes to wake itself up before.

Oddly enough, I can still wake the device with the typecover (keys or trackpad) and the USB mouse connected to the docking station. This is strange because I've disabled every device from waking up the SP3. Ive made sure of this through the "wake_enable" command in the command prompt which gives me a reply of "none." I can live with this, but it's still strange and can potentially lead to future bothers.

Regardless, thanks for all the advice! Maybe the SP3 just needed a long shut down.
 

Staff online

Members online

Top