What's new

Sp3 won't sleep or hibernate

I've always had problems with the SP3 not waking when it should and not sleeping when it should, but it seems noticeably worse with Win 10. Anyone else experience this?

My biggest complaint is that the unit refuses to hibernate. If I hibernate it, it goes dark for a handful of seconds and then starts up again, often with the fan running!

It doesn't seem to matter what I leave running when I hibernate. I can leave nothing running and it still won't hibernate (ditto for sleep)
The problem seems exacerbated when I leave it in the dock. I have checked as many devices as I could think of in the device manager to make sure they are not allowed to wake up the device.

What this means is that the unit is worthless to be as a "convenience tablet" because I have to power it off and on every single time, which takes considerable time to do.

I can't believe MS hasn't gotten there arms around the sleep/wake problems yet with these devices. My lack of confidence in them addressing this is the main reason I haven't, and probably never will, buy an SP4.

Michael
 

leeshor

Well-Known Member
You need to check several place to see what app is causing that. I don't think it is either your SP3 or Windows 10. Check the Windows system and application logs. Do a battery use report and try a "powercfg /lastwake" command.
 
Will try those suggestions. Thanks. Also, I was talking to a salesman about this at the MS store recently. He noted that MS acknowledges a bug in both the SP3 and Sp4 firmware that causes it to not sleep/hibernate always when it should, and told me this is being addressed in an update to be release on 1/29. I did a search on upcoming releases but didn't see anything. Guess we'll know soon!
 
Will try those suggestions. Thanks. Also, I was talking to a salesman about this at the MS store recently. He noted that MS acknowledges a bug in both the SP3 and Sp4 firmware that causes it to not sleep/hibernate always when it should, and told me this is being addressed in an update to be release on 1/29. I did a search on upcoming releases but didn't see anything. Guess we'll know soon!
LOL, just tried this.. Hibernated the system and it came right back on.
System log shows an entry for "Power-Troubleshooter" with a message that says "The system has returned from a low power state, Wake Source = Unknown".

And powercfg /lastwake shows this very informative data:

Wake History Count - 1
Wake History [0]
Wake Source Count - 0
 

Members online

Top