What's new

SP4 with MS Wireless Display adapter


I have both MS Wireless Display Adapter version 1 and 2 devices. When I tried to connect using SP4, the first attempt always failed. I had to try to connect it again for the second time then the chances are 90% will be successfully connected. I tried to delete from settings/ connected devices, etc and still having the same issue until now.
Is this normal? or any clue how to fix it?


Just to add, file Explorer now crashes when I open it while the MWDA is connected. And also whenever I use a program with file explorer dialog box action during 'open' or 'save' the program will crash. This is really annoying when doing software presentation.
Anyone here having similar issue and found the solution to fix this?


New Member
I have the exact same experience. My LenovoX1 Carbon that is 3 years old connects first try every time.

I get the explorer crashes too.


New Member
Same here.... I've had this issue with the original adapter, and then I bought the new one in the hopes the issue was fixed but it wasn't. I've spent hours Googling forums to see if anyone had a fix for this..


New Member
Same Problem here. Searching für a Solution für months now. Tried every fix i found including resetting the device multiple times.
The problem is conpletely stable, it even happens with different WDAs, doesnt even matter if v1 or v2.
Problem seems tonbe the Surface itself, not the Adapter.
But hey, nobody cares at Microsoft ...


I never had Explorer crash on me. But I also had my MSWD set to extended display and not mirror. You can try that and see if it helps. My SP4 would also not connect after pairing unless I went into Display Settings and selected the Connect to a Wireless Display link.