What's new

USB Connection kills Miracast connection


New Member
Hi there,

so I have a Surface Pro 4 (Base Model Core M) and ordered the Microsoft Wireless Display Adapter along with it.
I installed it all at home and the surface Pro had no problem whatsoever connecting to the display Adapter on the back of my TV.

I brought it to work, plugged in the USB to Ethernet dongle (also the one from Microsoft) and tried to establish a connection to the Wireless display Adapter 2 Meters away in plain sight. The SP does see the Adapter, the adapter says "connecting" but the connection shaky at best if it comes to live at all. We are talking about 90%ish fail rate here.
This has been going on for 2 days and it left me scratching my head. So I tried it at work without the USB-Ethernet dongle and things got much better. I had only one failed attempt. With an active connection I plugged in a USB3 Thumb drive and my Miracast connection froze almost instantly.

Both SP4 and wireless display adapter have the newest software installed (unless there was a firmware update for the SP, which didn't come with the Windows Update).

I begged our admin and got a WiFi AP but I still need the USB Port from time to time.

So what do you think? Anyone with similar experiences? Any advice?
Crazy, but...

Your TV with the adapter may be situated in a "node" of electromagnetic interference. You may have lots of electronics within close proximity to one another, making a noisy environment.

In cases like this, culprits are usually:
- Power bricks
- Analog to digital converters, audio and video, such as cable boxes, satellite boxes, Slingbox
- Audio amplifiers, which are essentially specialized power bricks
- Hard drives
- Routers

You may have just the "wrong" mix.
If possible, to isolate the issue, move your TV temporarily to another location. Try to connect.

It happens. I've got stories ...

If you get some success, let us know, then we can go the next step. There are things you can do.
Hmm you misunderstood me there.

At home, where the wireless Adapter is sitting behind the TV, it works flawlessly.

At work, where there are no obstacles, I have these problems.

I will try it at home again and use the USB Port. If I get the same problem here, then I guess there is not much I can do about it?
You may have interference, wherever the problem is. The obstacles are more likely electronic, not physical.
Let us know how using the USB port performs. We want to get you fixed up. ;)
Last edited:
I own a SP4 i7/16/512 and my wireless connection at home is rock solid. However, if I connect a USB thumb drive and start copying large amounts of data the wireless signal is lost almost immediately and then returns when I remove the thumb drive. I guess this could be a similar issue.