What's new

SPRO3 Type Cover Not Detected

TeknoBlast

Active Member
Started as of yesterday, my type cover doesnt get detected. This has happened before and after a couple of restarts, I'm back in business.

However, this time it's an entire day that I can get the type cover detected.

I searched and found posts about looking into Device Manager going to the Other section and updating the driver. Well I dont get the Other section. What I do get under Keyboard, is an entry called HID keyboard. I've uninstalled that and restarted the Surface, but nothing still. I also did the same process but with the cover off and I still get the same result.

The only thing I can do is take my Surface and keyboard to the MS store and test one of their keyboards and hopefully rule out that the Surface itself is not an issue.

The type cover wont even light up like it usually does. It's like the entire keyboard is dead.

Anyone here have any advise to troubleshoot this? I'm in the IT field and really tech savvy, but this issue has stumped me.

Thanks.
 
OP
TeknoBlast

TeknoBlast

Active Member
I tested my Surface with a keyboard from my job and it did not work. I took my keyboard and placed it on my work's Surface and it did work.

So the issue now lies with the Surface device itself. I'm currently doing a factory restore and hopefully that helps.

I guess a question for all, would you think the keyboard connectors on the Surface would wear out in time that it got to the point that the keyboard connectors cant make contact? I dont take off the cover that often to make it wear away.

I guess we'll see when it's done restoring.
 

ScottyS

Active Member
I had this problem, my keyboard worked on other Surfaces, their keyboards wouldn't work on mine. I did a restore and it didn't help (I think it was a firmware update malfunction).

Took it to a Microsoft store (since I had the extended warrantee) and they tried my keyboard on other Surfaces and it works, tried the other keyboards on mine and they didn't work, so then they did a restore. I told them I did all that but they said they had to do it for themselves. Then they gave me a new Surface.
 

mickjf

New Member
I had this happen to mine and in the end the simple 2 button shutdown method worked for me. You can google it but from memory:

While the type cover is connected, hold down the power and volume up button simultaneously for at least 15 seconds (during which time it may restart and go the BIOS screen, etc but you must hold both buttons for the full 15 seconds). After this wait 10 seconds then hit the power button as normal. Hopefully that should fix it.
 

Staff online

Members online

Top