What's new

SSD has no recovery partition.


New Member

I have a Surface Pro 7. I was playing around with it, and installed Ubuntu to see what worked and what didn't. In the process I wiped out all the partitions on the ssd to start clean.

After using it some time, I want to give this surface to someone, and I want to bring it back to Windows 11. And I've tried the following:
  • Installing Windows 11 from a bootable USB drive:
    • This didn't work, because the windows installer for some reason can't find the SSD. Which is shocking, being that this is a microsoft product.
I did some reading, and it seems like the way to go is to create a recovery USB. The problem is that I don't have another Windows machine. The wife has a Mac and all my other machines are linux.

So, what are my options? I've tried searching online, because I assumed I'm not the only one with this issue, but I've come up short.

Any help would be appreciated.



Super Moderator
Staff member
A. you could create a Windows Virtual machine on MAC or Linux
B. you can use a utility to create the USB on a MAC. Rufus for Mac Download | Create Bootable USB on Mac
C. If the Windows Installer doesn't see the SSD it is possible the Recovery Drive won't either ... boot back to the Widows Installer ... find the Advanced menu - Command Prompt - run DISKPART CLEAN on the SSD

Linux often leaves a disk in a state Windows doesn't recognize

Type the following command to launch DiskPart and press Enter: diskpart
Type the following command to list all active drives and press Enter: list disk

Microsoft DiskPart version 10.0.22621.1​

Copyright (C) Microsoft Corporation.​
DISKPART> list disk​
Disk ### Status Size Free Dyn Gpt​
-------- ------------- ------- ------- --- ---​
Disk 0 Online 238 GB 2048 KB *​
DISKPART> select disk 0​
Disk 0 is now the selected disk.​

Type the following command to select the drive to clean and press Enter: select disk 0
Type the following command to wipe out the drive and press Enter: clean
Type the following command to confirm that the drive is still selected and press Enter: list disk
type Exit and press Enter to leave diskpart

Please note that these steps will erase everything on the selected drive, and you cannot undo the changes. If multiple drives are connected to your device, disconnect them to avoid selecting the wrong one.



New Member
Thanks for the response. I ended up creating an VM on my unraid server and created the USB there.

But now I have another problem. After the recovery disk did it's thing. When the machine booted up, the welcome screen has the logo of the company that original bought this surface. It's asking me to type a valid login for the company.

Is this because the image I downloaded with the serial number is tied to that company? I think that's the only explanation, since the SSD had been wiped completely.

Is this the case? If so, how can I download a "vanilla" recovery image?



Super Moderator
Staff member
this is because the device is registered by serial number in a management platform such as InTune etc. You have to get the company to remove the device from the management platform. It has nothing to do with the downloaded image, the same thing would happen if you built a generic Windows Install USB.