What's new

Surface 3 Freezing at low power, can't find anyone else with this problem - HELP PLEASE


New Member
Hey people, I'm a big fan of the surface range and have both a Surface Pro 3 and a Surface 3 for my son. Now the problem I'm having here is related to the Surface 3 (Windows 10), it has had a light use life during it's first year but now that it is just outside of it's warranty (typical) the system has developed an annoying quirk. The system will work fine on battery all the way down to around 13% battery at which point the Surface 3 freezes and locks up. The only thing that can be done is to hold the power button to forcibly turn it off.

If you try and turn it back on right away the system will likely load but shortly after the desktop appears the system will freeze. The time it takes to freeze from boot is varies slightly but in all cases is short, maybe a couple of mins.

Sometimes when these freezes occur the system is trying to display the blue screen "Your computer has encountered a problem" screen (with the sad face) but it is only partially displayed and the system requires the power to be held to forcibly shut down as described earlier.

However if the tablet is left off and charged to the full it works perfectly until it reaches the 13% mark again.

Could this be a version of the inaccurate battery gauge issue that effected some of the Surface Pro 3's which was later fixed by a firmware update?

So far I have tried uninstalling the battery management from the device manager, forcing the system to reinstall it on boot but no luck. Also I have tried a system reset but again no luck so far. I have done a lot of net hunting on this issue and while I can find many battery issue threads I haven't seen anything that fits my scenario.

Any help or advice anyone can give will be gratefully received. I'm doing my best to avoid MS's offer of sending the unit back for an out of warranty repair at £150. Frankly even if I can't find a fix I will likely live with the issue for a while in case there is a driver or firmware update that comes out and resolves this at some point.

Thanks in advance! :)