What's new

Surface book base doesn’t charge


New Member
Hi, When I took my laptop after 4 days it didn’t start I tried the long press power , volume and power together but nothing worked.when I connected the power cable, the led on the power cable was on but it didn’t switch on the laptop The light on the detach key was red. So I detached the clipboard using paper clips and charged it separately and it was charging and the laptop was switched on. Once it was fully charged I attached it back to the keyboard . And when I tried to charge it , it shows battery 2 aka base battery is 100% charged and battery 1 was draining very quickly. The plug in symbol was not displaying in the task bar while charging. Once the battery 1 (clipboard or tablet) drops to zero which happen within half an hour. The laptop gets shut down. Again when I remove the clipboard and charge it , it gets charged. After again attaching it to the base the process repeats. Keyboard buttons and mouse operations are working fine. But charging is not happening in the base or keyboard And I tried to connect the external hard disk to the base and it doesn’t recognise it as well. Can someone guide me how to solve this problem.

I tried to uninstall battery drivers and reinstall it but it didn’t fix the issue


Staff member
You may be in a firmware loop which tries to manage charging, but runs out of juice itself.

Let's try this:
Leave the base and clipboard plugged in with the white LED on for several hours.