What's new

Surface Book cannot connect Wifi


after my troubles with a SP4 last year which I returned, I decided to give it another go with a Surface Book after seeing positive reviews with the latest updates being rolled out.

It's stable, no blue screens, no GDi crashes, however, I have the very same problem I had with the SP4 and a friend's Surface Book last year:

I can connect to most networks fine, but some routers, including the one I have at home (Netgear WNR3500v2), the SB simply can't connect to.
Either the passkey isn't accepted or if it is, it tries to verify the connection resulting in "unable to connect to this network".

I tried the usual spiel of

- re-imaging
- updating to the latest drivers (April update)
- changing driver settings from Auto to 5 or 2.4 GHz
- trying different auth protocols on the router, with an open connection I get limited connectivity

I then replaced the Netgear with my old BT Home Hub. After a few "unable to connect to this network" errors it eventually connected and seemed quite stable for half a day.

By now, still with the BT Hub, it only connects 50% of the time and even if it is connected reporting internet connection, I can't reach any site.

I just got off the phone with MS "technical" support who say that if the problem is not resolved by a rebuild, the only Option they have is to do an exchange of the device.

Given my experience with other Surface devices, this seems to be a problem with the driver or network stack. Looking at Microsoft's approach, there is no capacity or interest in troubleshooting this, so I am really left with no choice but returning this too for a refund which I would hate to do - this is a lovely piece of hardware.

What else can I do?


Active Member
What security are you using? I have seen issues with both WEP and/or WPA on older/inexpensive devices in the past

Have you checked netgear's website/forums for "unable to connect"
Have you checked for updated router firmware?

If you're connecting to "some" networks fine, this would seem to indicate the wifi card is operating as intended, which suggests the problem is either the router or the connection between those two specific pieces of hardware.

Best advice is to go buy a top end router like the Asus RT-6800u from a brick and mortar store [save your receipt] take it home and set it up/see if it works. If it works, then you know 100% it's the router.

Then either keep expensive router, or return expensive router citing buyer's remorse [it's ok, that's what return policies are for] and pick up something that more fits your needs. The reason for starting with a top end premium model is that companies TEND to support their top of the line hardware better, which will be a huge potential asset if you still encounter issues. I threw the Asus out only because I have one, it works, and out of the box my SB had no issues connecting to it.

FWIW, I've owned a few netgear routers over the years, and I have yet to find one that works worth a bowel movement. Range issues, intermittent connectivity, finicky about devices, etc, which is why I recommend using a DIFFERENT brand to test with [that and to make sure it's not something specific to that particular manufacturer]


Active Member
I have found that 95% of the time when I have a problem with connectivity to a wireless router, updating the firmware of the router fixes the issue. I also am not a Netgear fan, although I have had problems with routers from all the major manufacturers.


oThank you for your replies. I somehow got it working with the Home Hub for the moment, probably until the next reboot.

While I understand and appreciate the advice, I have a few concerns with buying a new router:

- after having spent over two Grand for this, I am not to keen on spending even more, particularly for what seems a driver issue with the Skylake generation of Surface devices. Having to take a trial and error approach in choosing a new router until I actually understand the underlying issue doesn't make this an appealing option either.
- I too saw bad reviews for Netgear routers but I have to say that mine served me quite well over the past years and I have not had a single issue. Every other device I owned (Android,iOS, Windows 7/8/10 machines, Linux, MacOS...) had no problem connecting - apart from an Asus Book with a dud Atheros OEM driver.
- replacing my home router won't help me if I am out and about. I have no control over what routers are used out there. Not being compatible with a set of routers and not knowing whether I can connect is a problem.

So I am wondering whether anyone else experienced smilar problems or perhaps there is an obvious step I am missing.

In regards to Seneleron's questions:

- I looked into the Netgear forum and found quite a few entries in regards to the SP3 which was eventually solved by a driver update for the Marvell adapter.
- yes the latest firmware is installed. I tried a factory reset of the router and tried two previous versions of the firmware without success
- I tried all authentication options, WEP, WPA-PSK, WPA2-PSK and "None" without success.


Staff member

I wonder if the problem is IPv6 or IPv4. In "Network Connections", check the settings of Internet Protocol Version 4, and Internet Protocol Version 6. It could be that you have been configured somehow along the way for static IP address or the wrong servers or proxies.

Because your original complaint was you can connect to most networks without problems, it makes me suspect the problem is NOT a router, but your adapter settings.


Active Member
The other thing to try is straight uninstalling the WiFi card in device manager and restarting. It SHOULD auto reinstall the driver on restart, which will [iirc] also reset all WiFi settings to default.

Just make sure you still have the driver on hand just in case.


I had tried to uninstall drivers (both delete driver software and keep it) to no avail.

I checked IPv4 and it's set to get the address automatically. Tried a static address within the address range pointing to the router address as gateway without luck.

Disabled IPv6, still no luck.

I guess I'm somewhat lucky to have an affected router at home so I'll try a netmon next.

It talks to the router but it seems that the negotiation fails for some reason - unfortunately, the router logs and the SB event logs show no related entries.