What's new

Surface Mail App - Attachments


New Member
Not sure how to explain this except to say that the application does not always download attachments or even indicate that one is present.

I ran some tests and think I figured out part of this issue.

Basically, my daughter sent me a bunch of pictures in email to my charter.net account. The mail app is setup correctly and I have had no issues pulling mail however, for this series of messages no attachments were present even though I knew they were supposed to contain them. When I opened each message all I had was basically a blank shell. Nothing else. I tried synching with no progress. I assumed that she forgot to attach the pictures so I replied to the message and a prompt came up telling me that the message had not finished downloading and asked me if I wanted to continue of finish downloading to which I responded for it to finish.

Short story is that I needed to “reply” to each message in order to finish the download process via the prompt.

I tested this repeatedly and even sent myself other attachments to include JPG, DOC, PPT, PDF…etc.
For these tests, all attachments came thru the system just fine yet the original messages from my daughter still had issues. In addition, one thing that did stand out was that in every email I sent with an attachment I had the typical “paperclip” telling me that I had an attachment waiting with a prompt asking me if I wanted to download them. This did not hold true with the messages from my daughter. While they all had a picture, none of them had the paperclip and none were recognized by the mail app as having an attachment (at least not until I replied to each one and I got that crazy prompt).

I decided to open these same messages in an iPad and was surprised to see that these same messages this time, the ones from my daughter, they all had a paperclip.


As it turns out the messages originally sent by my daughter were done so from an iPad via iCloud service. She “shared” the pictures with me from that service. They came across as a message but they were not recognized correctly by the mail app.

The interesting part in all of this is that mail app failed to see that an attachment at all was present yet did see that the message was not fully downloaded (even though it did not tell you this directly).

This certainly is a problem but I cannot say on which end (Apple message formatting or MS not reading the email header / body correctly).
Last edited:


Super Moderator
Welcome to the forum. That is a good question. Do the attachments come through on a PC or Android device or even by going to your mail via the browser on the Surface (there may even be a difference in IE app and desktop IE in that case)? If not I'd say it is Apple being proprietary and only making it easy on other Apple users. If PCs and Android devices don't have an issue then I would say it is something in the MS mail app. The mail app is certainly far from being robust.


New Member
I did test this with IE logging into the webmail client. The attachments did show up correctly via the webmail client. This looks more and more like an issue with the mail app.


Super Moderator
I'm not surprised the mail app is pretty simple. It works well in most cases but there are plenty of discussions about its shortcomings as well. Many think the included MS apps generally seem to feel unpolished. Fortunately any shortcomings can (and hopefully will) be fixed through updates.

Staff online

Members online