What's new

Surface Pro 4 Camera App Doesn't Save Videos


New Member
Hi everyone.

I have this strange problem with my surface where when I take videos, the camera app behaves like it's taking the video (it has the timer going at the bottom), but after I press the stop button, the video doesn't save properly in the camera roll. Instead, it saves a correctly named 81KB unplayable video file.

Photos still work fine.

Originally I had problems with videos because it had the syncing symbol (but I have no internet), so I disabled OneDrive uploads. Now it doesn't have that symbol but it still doesn't save the video correctly.

If I restart the device, videos record normally for an unknown amount of time before this problem returns.

Any ideas?



New Member
Hello i have exactly your same problem. If i use the camera i only obtain an unplayable file of 81kb with zero messages on what's happened.


New Member
Just an update, now camera works fine. I contacted the Microsoft support. We have done these things in order.
1) tried to uninstall and reinstall the camera software again.
2) after this, the camera worked but cortana didn't work anymore
3) the technician told me that something has gone wrong with an windows update so i sohuld try to use the sysyem recovery that re-install windows files.

All this process has been more than 6 hours long.

And in my opinion the main problem is that the system is not verbose in describing whats going wrong.