What's new

Surface Pro 4 streaming lag?

Philtastic

Active Member
I think you're focused on the wrong thing. I can have multiple applications running on an ASUS laptop that has the i5 processor, running Windows 10, and stream flawlessly. But I make sure everything on my Surface is closed fully before trying to stream a movie, yet it still hiccups.
I'm asking because you might have background tasks running in the background taking up CPU cycles which would cause both stutter in videos as well as drain your battery. The fact that everything is apparently closed on your Surface heightens the need to check for things running in the background... things like virus scanners that take up both CPU and storage bandwidth.

Edit: Also, laptops have much faster processors than what the Surface Pro and other ultrabooks use so they could have the same background applications running but not feel a thing.
 

jnjroach

Administrator
Staff member
The only time I experienced any lag in video was when the device first shipped with the gimped video driver....

So either your video driver is out of date or you have malware....
 
OP
S

Sc0tchW4rr10r

New Member
Welp, my video driver is up-to-date and I've scanned my computer a few times now, no threats/malware detected. As for the background processes, I average under 10% CPU most of the time, right now being 4-8%. But I even took Cortana out of the mix, and the lags still continue.
 

Philtastic

Active Member
Ok, that's odd then. I presume that this continues even after a restart? If it does, I have no idea what's wrong. Have you done any tweaks? Are you running on battery saver mode or the power saving profile accidentally (in fact, is there a difference if you're on charger vs. battery?)?
 

jnjroach

Administrator
Staff member
Do you experience the lag on all networks? What does Speedtest show? The Marvell WLAN doesn't play well with many consumer (especially Telco/Cable provided) routers.

If all else fails, do a factory reset.
 

bluegrass

Well-Known Member
Welp, my video driver is up-to-date and I've scanned my computer a few times now, no threats/malware detected. As for the background processes, I average under 10% CPU most of the time, right now being 4-8%. But I even took Cortana out of the mix, and the lags still continue.

If you haven't already, you should scan for malware with Malwarebytes. It has fixed a ton of computers I service over the past dozen years.
 

Members online

Top