What's new

Surface RT

eskiemama

New Member
Hi Everyone!

My husband bought me a Surface RT, which I absolutely love! I have been playing games on Facebook since I got it with no problems! I was playing one of the games yesterday afternoon and everything was fine! Last night I went to play and it is now telling me that there is a certificate error and the page won't open, it just keeps trying to reload! At first I thought it was just for that game, but it seems like all the games I played with no problems are now doing this!

Anyone know why this is happening and is it possible to fix it?
 

Omni

Active Member
That's a strange one. Is the time and date correct on the Surface as that can cause certificate errors?

Are you using the Facebook app or Internet Explorer?
 
OP
E

eskiemama

New Member
Yes the date and time are correct, that was the first thing I checked! I'm using Internet Explorer! At first I thought Facebook was having a problem, but when I get on my husbands laptop everything loads fine!
 

Omni

Active Member
Do you know if there flash based games? If so there could be a problem with flash. Might be worth trying the app as well that might work better.
 
OP
E

eskiemama

New Member
I was thinking it could be the flash and checked everything out with that, all seems ok with it. Everything is up to date. The strange thing is that it was working and then about two hours later it wasn't!!! There were no updates done during those two hours so I don't have a clue what could have changed to make it all stop working! I'm so baffled loll

Oh and it seems to be doing it with every game on Facebook! I'm thinking it could be a setting with Facebook but again I hadn't changed anything within the two hours it stopped working!!
 
Last edited:

Omni

Active Member
Go to the control panel (desktop), System and Security and then Flash Player at the bottom. Click the Delete All button. Then the advanced tab and click Delete All again. Try again.

I have no idea if that will work but worth a try. Are you using Modern IE or desktop one?
 
OP
E

eskiemama

New Member
Well I went in and deleted all and it's still doing the same thing!!!

I've used both the modern IE and the desk top one. Both were working fine and now both are not! It's so strange as I've gone over everything I can think of!!!! I'm almost wondering if I should do a restore for a few days back?
 

Omni

Active Member
Go to desktop IE, settings icon in the top right then Internet Options. Advanced tab then Reset at the bottom.

I'm not sure what else to try barring a refresh after that.
 
OP
E

eskiemama

New Member
Ok I did that still nothing! I tested the flash player, which seems to be ok. Although at one point it told me I wasn't using internet explorer so it couldn't run! But then when I scrolled down the test picture was working ok and it said I had the latest version. It just doesn't make any sense as to why its not working now lol
 

kristalsoldier

Well-Known Member
You reset the device and it is still not working right? Can you access other sites and do other stuff with the device?
 
OP
E

eskiemama

New Member
I can do everything I've been doing for weeks, since I got my tablet, except play any Facebook games!!!! I'm baffled as to why I was playing a Facebook game and two hours later I'm getting a certificate error. Now I'm not even getting the error, the screen just keeps flashing as it tries to reload over and over again! Then I either have trouble closing the page out or internet explorer freezes!

I talked to tech support for Microsoft and they are still in the process of trying to figure it out! I was hoping someone was possibly having the same issue!!! I'm usually pretty good with most computer issues, but this one has me very stumped!
 

Omni

Active Member
Im starting to wonder if facebook have changed something there end that's messing things up with IE 11. What game are you playing? Ive just tried one called dragon something and that seems to be working on my Surface 2.
 
Search tags for this page
certificate error on surface
microsoft surface certificate error
surface 2 certificate errors

surface certificate error

surface pro certificate error

surface rt certificate error

surface rt certificate errors
surface rt forum
surface rt forums
surface rt security certificate errors

Staff online

Members online

Top