What's new

Tether Somehow! USB or Bluetooth


New Member
Hello All!

I am in need of being able to connect my new Surface 2 through a phone connection. I was able to connect it last night, but think I know why. Here is the synopsis:

I have a Samsung Note 3 and on the phone I have FoxFi and EasyTether Pro. Both apps have been successful in being able to connect my phone to another device for internet connection. I can use FoxFi for Bluetooth tethers and I can use EasyTether Pro for USB tethering. The problem is the FoxFi works on my other 7"tablet because I am able to use an application on that device called PDANet Tablet. I am able to use the EasyTether Pro on my laptop as a USB tethered connection because EasyTether Pro has an .exe file I can install and it recognizes the phone as a modem and allows connection. These both work great.

Now on the Surface 2 there is no PDANet available for it, and I cannot install the EasyTether Pro executable on it either (Windows RT). So I was trying to just get the Bluetooth tether to work without the other side applications that these 2 apps normally work with. Neither worked. When I was about to give up all hope, I thought I would just use the Bluetooth Tether option that is built into the phones OS (Kit Kat Android 4.4).

Now it must be advised I have noticed 2 things about paring my phone with the Surface. First is that if I do not have Bluetooth tethering enabled and I pair the phone up, when I go into devices and choose connect using it shows "Direct Connect" and doesn’t work. However, if I have the Bluetooth tethering enable on the phone and then pair the phone with the Surface(Have to remove device and re-pair with phone) it will show the connect using option of "Access Point"

So, I enable it and then go to the network connections. Choose Bluetooth network, which brings up the phone. I choose connect using - Access Point.. and viola I was able to connect to the internet! Now I thought I had fool proofed this. I had turned off the Wi-Fi on the Surface 2 to ensure it wasn’t on my home network for connection. Also before anyone asks why I don’t just use the home network, I do, I just was setting up for being able to use the Surface 2 while on the go. Anyways, it was working; I was ecstatic and was finally set on not taking it back to Best But. Now like I said, I thought I had fool proofed it and it was going to work.

I came into work today and I went in and chose the phone to connect using access point and the connect using option had changed to direct connection and didn’t work. No problem, I simply removed it and re-paired it while the tether was enabled. Then chose connect using and Access Point was back again. Clicked connect and it shows the little Bluetooth pop-up showing connecting, and then successfully connected. I also pay attention to the bottom of the screen where it shows the phone icon and then shows Connection Status. If it doesn’t work Connection status will show disconnected, but it did not show that. So I thought everything was a go.

It wasn’t. It will not bring up a web page. So I went back into the network connections. It shows that the Bluetooth connection is there, and I checked desktop and the Bluetooth Network connection was showing connected internet in the System Tray. So then I went into the connection itself and it shows the Surface is sending just fine, but its receiving is staying at "0".

After playing around with this for an hour, and thinking what would have changed from last night to today and it dawned on me that even though the Surface was not connected to Wi-Fi my phone was. So I am not sure if it worked last night because my phone was simply sharing its Wi-Fi connection to my home network and now that it is on the phones network it won’t share it ... or if I am just missing something. I plan to try it again when I get home, but though I would come here to see what options I have, or if someone has found a work around with this. Other than calling and adding the Wi-Fi Hotspot feature from my provider on to my plan. My carrier (although I have unlimited data) only allows like a 5 GB or 10GB add on Hot Spot feature. Which I know I would exceed, plus I don’t believe in paying for data twice.. but that’s a whole other story.

Also I wanted to ask, because I thought about using the phones built in USB tether option as well. When I connect my phone via USB on the side port of the Surface 2, it doesn’t respond at all. Meaning it doesn’t show any new Hardware recognition or that even possibly an external hardware device has been connected. It doesn’t show in Device manager or my computer. When in Device manager when I click to choose to look for hardware changes I get nothing. However the phone is getting a charge from the connection, so it does show it is getting power, but the phone doesn’t even ask if it is OK to connect as media device. So, if you could help with this too, it would be greatly appreciated.

Thanks for any help anyone can provide. I am within 15 days of return policy with Best Boy and already thinking about returning, but love the concept the Surface 2 provides. I just need to be able to access the internet.

Thank You Again


Active Member
Have you tried just setting up a WiFi hotspot and seeing if that works? Ive never tried setting up via Bluetooth but surely the method is irrelevant as the carrier can still see what data is been transmitted.

Unfortunately Windows is something my carrier detects straight away so I have no choice but to pay for it.


Well-Known Member
yea I have a note 2 and I tether my S2 via the wifi hotspot all the time...don't over complicate things with this app and that app... just enable the hotspot and surf away


Active Member
Yes. Hotspot works fine. But, he is asking about using the phone as a modem, PAM, via tether USB or BT as he does not have hotspot currently enabled via his carrier.

Without PDANET client or something to interpret the strings on the surface, this wont work unless you can program yourself. It would work with SP1 or SP2, but not on metro currently.


New Member
i have an iphone 5 and I find that bluetooth tethering my SP2 constantly drops connection. Wifi personal hotspot works well, but it's just annoying to have to go into settings on my phone every time i want to connect.