What's new

Type-Cover isn't working suddenly


New Member
Dear Community

I have a big problem. My Surface Pro 3 can’t detect my Type-Cover anymore (there’s no light). Until now there have been no problems, but suddenly nothing works. I tried out the Type-Cover of my wife, but that isn’t working too. On the other hand side, my Type-Cover is working on the Surface Pro 3 of my wife. So I think a failure relating to my Type-Cover itself could be excluded.

But I couldn’t imagine that the problem is related to the Surface. Because it is only one year old, it never felt down, and was never exposed to some heat, coldness or high humidity.

Things I have tried out, yet:

1. Restart Surface

2. Drop off and connecting Type-Cover

3. Update Windows 10 Pro 1511

4. Cleaning the pins on the bottom of the Surface

5. Reinstallation of the HID drivers

Nothing of these things worked…

Is it possible that there’s a function in Win 10 to inactivate the Type-Cover manually or is there the possibility to check out if the Type Cover is even connected?

Greetings from Germany



If you go to your device manager, under keyboards, do you see Surface Type Cover Filter Device? It's normally supposed to be there, but if you have the same problem that I did, you might be seeing only HID Keyboard Device two times. Also, while your type cover is plugged into your Surface, if you press Fn+F1 or Fn+F2, do the lights on your keyboard go on or off?

If you're seeing all of the above, then you're having the same problem that I did.

Try this:

Hold the power button and the volume button (both up and down) together for about a minute. This will do a soft reset and force your Surface Pro 3 to shut off. And when you turn it back on, hopefully, all of the drivers reset, and the type cover will work again.