What's new

Unable to change screen resolution


New Member
I've been a long time lurker but this is my first post, I'm hoping someone can help me out.

I seem to have the problem that others have had at a time, and that is changing the screen resolution on a SP. Whenever the resolution is changed it does not scale and black bars are simply added around the screen.

I am running Win 8.1 with the current updates, and my video driver is

I've tried different video drivers to no avail, and cannot seem to get the Intel Management and Control people talk about.

Any help would be greatly appreciated.


New Member
Hey Johnnyw,

I reset my SP on the weekend in order to get the 8.1 Update to work (that's the latest one and not the 8.1 upgrade from 8.0)
Just looked and my Graphics Driver is and my screen scales when the resolution is changed.

Hope that helps.


New Member
Seems to be the 2014-03-11 update has a newer video driver that does not have the Intel Management and Control panel. I downloaded the older video driver you mentioned, disabled automatic updates and changed the driver for the

Everything works now.