What's new

Unable to ping Surface RT after a while.

gusto

New Member
I have a homegroup set up with a Windows 8 desktop and my Surface RT. I'm intermittently unable to ping the Surface either by name or by IP from the desktop. I seem to consistently run into this problem. After restarting the Surface, I can ping it successfully, but after some amount of time (not sure exactly how much but probably on the order of hours rather than minutes) can no longer do so without restarting again. I fail to do so both by name and by IP. I can ping the desktop from the Surface.

Anyone else seen anything like this or know what might be going on?
 

pallentx

New Member
Could it be going into a powersave mode? The Surface isn't really intended to be an always on device like a server or desktop. Although it has "connected standby", I'm guessing this is not a constant live connection - perhaps more of an intermittent wake up and ping for updates kind of thing. If its up and running and you're losing connection, then I don't know. I haven't seen anything like that.
 

J515OP

Super Moderator
It is possible your router is having trouble assigning addresses. Maybe try a router reset?
 

Inadorel

Member
My mother had this problem with her RT. It is related to powersaving - but it is in the network card properties. Go to Control Panel, Network, Network Connections and then properties of the connection. Go to Configure the Adaptor and then choose Advanced. Under power management - take the tick off 'Allow the computer to turn off the device to save power'. This fixed her problem - yours sounds the same to me.
 
OP
G

gusto

New Member
Thanks for the replies.

My issues with connecting to the surface are not because it's currently in powersave mode. I'm unable to ping it even while actively using the device (and while pinging from the device to my desktop, for example).

It may be the case that the device is entering a powersave mode, disabling the network adapter, and then failing to re-enable it properly once it exits powersave. I'll try modifying the setting you suggested Inadorel. However, if that does end up being the issue, it seems strange as the adapter was clearly re-enabled to at least some extent, given I can still make outgoing connections from the surface.

For similar reasons, I wouldn't think it's a problem with the router issuing IPs, as the surface still shows itself as having the same IP and the client list on the router still includes that machine.

I'll report back tomorrow on whether I run into this again after changing the adapter setting. Thanks.
 
OP
G

gusto

New Member
So I disabled 'Allow the computer to turn off the device to save power' on the wireless adapter. After doing so, my surface would crash any time it hit powersave mode. I reenabled the setting, and I no longer get crashes (but still lose my ability to ping eventually).
 

pallentx

New Member
crazy. I have no idea on that. I think I would call support and see if they have any help. Sounds like a hardware thing, but I might be wrong. Are you up on all the latest firmware updates?
 

Omni

Active Member
I've just tried pinging my RT but it just times out. Not sure why but my surface works perfectly and this is not a issue for me. Might help you though I hope.
 
Search tags for this page
can not ping surface 3 tablet
can not ping to surface rt
can you ping a surface

cannot ping surface pro 3

connected+standby ping
enable icmp surfacert
surface rt not responding to ping

surface rt ping

unable to ping surface pro 3
windows rt enable icmp

Members online

No members online now.
Top