What's new

USB 2 devices work - USB 3 devices not recognized

Not2Old2Fly

New Member
Been fighting this issue for many months. Finally broke down and took it to a local computer shop, and when I picked it up later the same day - EVERYTHING WORKED!! Hooray! He said he loaded drivers.

Within a couple of days, back to the same issues. Generic SuperSpeed USB hub is Code 31. Computer will recognize any USB 2 device (mouse receiver, CD drive, thumb drive) and all work correctly. However, computer does not see any USB 3 thumb drive OR SD card. I really need the connectivity.

Yes, I have run troubleshooter, deleted and reinstalled device, done everything I can think of. Maybe this has been hashed to death here already. If so, I couldn't find it. Apologize for my lack of computer savvy, I sincerely appreciate any help.
 
OP
N

Not2Old2Fly

New Member
Build - uhhhh, let's see:

Windows 10 Pro Version 1703 OS Build 15063.540
Not using a dock.

(Not sure if that's what you asked for or not - real computer illegitimate am I)
 

sharpuser

Super Moderator
Staff member
Okay, good Build. Thanks for that.

Download a full set of drivers from Microsoft here:
Download Surface Book Drivers and Firmware from Official Microsoft Download Center

Choose the top one of the list (.msi).

Run it. Updated drivers should install automatically. You won't notice much.

Then do a cold reboot:
1. Press and hold the volume-up button and the power button at the same time for at least 25 seconds. Do not release early, even if it appears that the screen or keyboard go dark.
2. Wait 10 seconds.
3. Press and release power button. On any UEFI or setup screen, exit without saving changes. Your Surface will restart.

Let us know how this goes.
 
OP
N

Not2Old2Fly

New Member
Thank you, sir. OK - Downloaded .msi file and tried to run it. It set up to run and I got the following message:
"A newer version of SurfaceBook Update 17_020_00 (64 bit) is already installed." Clicked OK, and had no option except to 'Finish'.
 
OP
N

Not2Old2Fly

New Member
I did a cold reboot as instructed, everything went fine, SurfaceBook came back up OK - except (isn't there always) a small, oblong black box in the upper left part of the screen with '100' at the bottom of a blue line going up through the box. I can't click it, move it or remove it. If I click the blue line, it goes down but climbs back up to 100 and stops. If it sounds like I don't know what I'm talking about - there's a good reason for that.
 

sharpuser

Super Moderator
Staff member
This may sound crazy, but switch your two Surface Book computers. Temporarily swap the keyboard bases with the clipboards. See if the USB 3 issue is with the computer or the base.

I also use two Surface Book computers. Swapping should work fine, since the keyboard only supplies peripheral devices and the primary battery.
 
OP
N

Not2Old2Fly

New Member
OK - so that was a nightmare. Swapped screens between computers. USB devices seemed OK on my wife's computer and my screen. Wasn't smooth, but things seemed to work, devices mounted and could be shut down. On my computer with her screen, USB 3 thumb drive would mount and then dismount, over and over, it would hold long enough to at least look at the contents but wouldn't stay up. SD drive on my computer, her screen, would never mount to the point I could see it - it would continuously mount and dismount every 5 seconds. Had to shut down and remove everything. When I returned the screens to their respective bases, her USB devices had problems - her mouse stopped working and the USB 3 thumb drive would mount but I couldn't look at it. Finally pulled everything out of her ports and did a cold reboot. Her machine started printing garbage on the screen instead of words. Restarted hers, ran troubleshooter, everything came back as OK except the front IR camera driver - no big deal, just something else to be worried about. My screen and base mounted the USB 3 thumb drive when repaired but dropped it and remounted it over and over, won't hold. SD card is not recognized. The USB 3 is trying to work now but keeps mounting and dropping. Currently there are no USB errors being reported by device manager. Don't know whether I helped anything or not. I hate computers.
 
Search tags for this page
azs

news

usb 3 not recognised

Members online

No members online now.
Top