What's new

USB-DVI Adapter Issues

ridgeburner

New Member
So I purchased one of the below in order to get my 2nd external up and working. From reading the forums/web it appeared that many people had great success with these type of devices. However, once I install the driver and get everything working my Internet Explorer just goes into lockdown mode. It will lockup, "ding" at me when I try to klik anything. When I go to Task Manager it shows extreme CPU and Mem use from IE. I kill the process and it calms down.

All other programs run normally with no issues. For w/e reason IE just pukes. If I uninstall the driver for the device all goes back to normal. Any ideas? TIA..

Device:

Amazon.com: StarTech.com USB 3.0 to DVI External Video Card Multi-Monitor Graphics Adapter With Built in 1-Port USB Hub - 1920x1200 / 1080p: Computers & Accessories
 

kundas1

Super Moderator
Staff member
doesn't MS already sell an adapter like that? you can buy them for like $30 bucks at BB/FS, also most new monitors use dvi/HDMI/VGA connectors so maybe you can use an HDMI connection? or is that not possible?
 
Last edited:

jnjroach

Administrator
Staff member
It appears that specific version uses a chipset from MTC not DisplayLink which has been the leader in this space.

Have you tried to make sure you have the latest driver?

Magic Control Technology Corp.

This is newer than the one listed at the StarTech site....
 
OP
R

ridgeburner

New Member
OK, I guess I was not too clear on what my problem is. I am currently using the DP, with an adapter, and have it plugged up to an External Monitor. The problem is I was trying to attach a SECOND external monitor via using a USB adapter (see link in OP).

I have found the problem, and I am going to post it here in case someone encounters this same issue. Apparently IE11 utilized GPU Acceleration. As a result that apparently drives this unit crazy when you add the USB Adapter. Now I cant say this is the case for all USB Adapters, or all Surfaces. However, it was definitely the problem with this Surface, and this Adapter..

To fix the issue I had to uninstall the driver for the adapter, open IE, and go to Internet Options/Advanced/and then check the box that says "use software rendering instead of GPU rendering". After this was checked I reinstalled the drivers and all worked fine.
 
Search tags for this page

dvi to hdmi adapter issue

dvi to hdmi adapter issues

microsoft surface usb dvi

reviews on surface hdmi connection

startech display adapter troubleshooting

startech usb 2 dvi troubleshooting

startek usb3 to hdmi surface book issues

surface usb to dvi adapter

usb to dvi adapter

usb to dvi on a surface

Members online

Top