What's new

Windows 10 Sleep Issues

exdox77

New Member
I upgraded to Windows 10 this week and now I am having sleep issues. When I press the sleep button the screen will turn off but then it will turn right back on. No matter if I use the button or the start menu. I had to manually shut down the computer for it to turn off. Has anyone else encountered this issue?
 

vap0rtranz

New Member
I just upgraded my SP Pro 1 to Win10 and had a similar issue with power states, but not your exact situation. I noticed my Surface was blazing hot after I closed the Touch keyboard and stuff it into my bag for an hour. It was still running full speed instead of going to Sleep.

Try playing around with the new Win10 settings related to power states. I'm not in front of my Surface, but I recall changing the new Background Apps that are allowed to stay running. Folks online have found certain apps (like Edge) can now stay running and keep burning through power, so maybe those kind of troublesome apps could be preventing your Surface from going to Sleep.

I also checked my Power Settings after the upgrade. I noticed that Win10 changed my Dimness values but kept the Power Profile (ex: Sleep on Lid Close). Maybe the upgrade changed more settings on your Surface, so just another thing to check.
 

vap0rtranz

New Member
P.S.: I remember now that Microsoft just pushed a firmware update to my Surface in addition to the Win10 upgrade. I believe the firmware was dated July 29th (not in front of my Surface). Since those firmware updates are device specific and can affect power states, I'd check that you got it. Microsoft may have needed to change our Pro's for Win10.
 

Magic

New Member
I've got the new firmware update installed. Although according to the Microsoft site there hasn't been one since January 2015...
 

neo17

New Member
Same issue here. My Surface Pro wakes up as soon as it gets into sleep mode as a result it is always running hot and fan is on most of the time.
 

eelpout

Member
count me in as well with my SP2. :(

But, using "powercfg -devicequery wake_armed" may have found a solution. it listed the following as candidates:
HID-compliant mouse
HID-compliant mouse (001)
Surface Type Cover Filter Device
HID Keyboard Device (001)

Going into the Device Manager, Power Management tab for each device and deselecting "Allow this device to wake the computer" seems to have solved preventing it going to sleep :). I tried differing combinations of having some of these on and some off and for me, it only works if they are all unchecked. So it looks like the Type Cover drivers are to blame. What's odd is even if the cover isn't connected it still won't sleep without these power setting adjustments.

Hope this helps someone else.
 

dleuen

Active Member
count me in as well with my SP2. :(

But, using "powercfg -devicequery wake_armed" may have found a solution. it listed the following as candidates:
HID-compliant mouse
HID-compliant mouse (001)
Surface Type Cover Filter Device
HID Keyboard Device (001)

Going into the Device Manager, Power Management tab for each device and deselecting "Allow this device to wake the computer" seems to have solved preventing it going to sleep :). I tried differing combinations of having some of these on and some off and for me, it only works if they are all unchecked. So it looks like the Type Cover drivers are to blame. What's odd is even if the cover isn't connected it still won't sleep without these power setting adjustments.

Hope this helps someone else.
Excellent work! That was it for my SP1 also. Saved me a ton of time.
 

Moonsurface

Super Moderator
Staff member
I just tried these things as I've been having this issue with win 10. It's a shame as I never had it with win 8.1 even when it was brand new I could just shut the cover walk away and come back even days later and it'd still be ready for use. But I have noticed since Win 10 upgrade that it's dead if I don't shut it down.

I had left it for a day or two recently and came back to it this morning to find it was completely dead. I ran the sleep report and could see that it had lost a ridiculous 55% of the battery on connected standby!!! I used to get very little loss at all. The biggest offender was wifi scanning/the wifi adapter.

I have since turned off the things suggested above, but also I have turned off Edge running as a background process. I will see if this helps - but any other suggestions would be appreciated.
 

GreyFox7

Super Moderator
Staff member
I had left it for a day or two recently and came back to it this morning to find it was completely dead. I ran the sleep report and could see that it had lost a ridiculous 55% of the battery on connected standby!!! I used to get very little loss at all. The biggest offender was wifi scanning/the wifi adapter.
Is it me, does W10 wakeup blazingly fast or does it just *never* sleep. Even when I leave it overnight you touch it and it's on instantly like the screen just blanked a second ago.
 
Search tags for this page
surface pro 2 sleep issues windows 10
surface pro windows 10 sleep
surface windows 10 sleep
win 10 sleep issue
windows 10 sleep issue

windows 10 sleep issues

windows 10 sleep issues on surface book
windows 10 sleep problem
windows 10 surface 2 pro sp2 sleep
windows 10 surface sleep issues

Members online

Top