What's new

128GB MicroSD card keeps unmounting/crashing

GreyFox7

Super Moderator
Staff member
This isn't a problem unique to the Surface 3. I came across this thread by Googling my error code 43 which is on an HP Pro 608 (Windows 10). It's the exact same problem everyone else is describing. Basically I can't simply boot up my tablet if I plan on using the microSD card (a 200GB SanDisk btw - supposedly the tablet supports mythical 2TB cards as well). Most of the time I have to reboot and then it typically works from then on.

I seriously doubt the problem is the card - the OP even tried three different 128GB cards. I tried formatting it in NTFS and changing the removal policy in Device Manager with no success. These are good suggestions but I'm very skeptical they work since not everyone is getting fixed. I think those who think they fixed it are experiencing what I consider a lucky coincidence which isn't going to last.

Wish there was a proven solution because it's quite maddening to have to boot your tablet twice before using it every time. I'm leaning towards this being some weird Windows driver issue not specific to the hardware. I mean - how can it be the hardware if it works fine after every reboot?
How it could be the hardware... timing is one example. the specifications may allow 10-20 microseconds for a response to a command or signal etc such as during recognition. if the card responds in 7-12 microseconds then a certain percentage of responses will likely fail or if the cards response was 15-25 microseconds, same issue. There are a number of ways this could be a hardware issue or implementation specific issue even if the "specifications" are adhered to because often there can be different interpretations of how it should be done and what's allowed or not allowed.

Standards are also complex and varied. Google is an easy example with Browser Standards but the same happens with almost all standards. Google will develop a new way of dong something then propose it as a standard. Often companies begin to adopt these proposals even before they are approved and it may be changed along the way before it is approved. now you have a variety of implementations from various states of the "standard", depending on who you want to believe. This is how the browser wars are fought and the same happens with other things as each vendor jockeys for an advantage over the others. SanDisk pushes the envelope here, Samsung there, CardReader manufacturers implement something ... firmware tries to adapt to ever moving targets. Sometimes it's amazing anything works at all.
 
Last edited:

kkckkc09

New Member
I have struggled with this issue for a couple of years, however last week, after a recent firmware & windows update on my sp3, the situation almost resulted in my dumping the sp3 in the trash with dismounts every 5 minutes. Here's what I did to resolve the situation (applies to Windows 10 1709 as well as 1803, may apply to other Windows versions too):

  1. Upgrade the driver for the Realtek USB 3.0 Card Reader to the latest version (27-2-2018, v10.0.16299.31241 in my case). This driver is not found on either Realtek’s website nor on MSFT’s website. I had to get it from a 3rd party website.
  2. Set Device Manager > Disk Drives > SDXC Card > Properties > Policies to “Better Performance”. Restart and allow Windows 10-15 mins to adjust whatever it needs to.
  3. Allow OneDrive, GoogleDrive to sync. I needed at least 10 restarts as the sdxc card kept dismounting before all 50,000 files/100GB were synced. But this is way better than restarting every 5 minutes.

To further reduce the dismount problem, set OneDrive settings to download files when needed. I prefer to have full file copies locally and that seems to cause cache write related congestion/conflicts(?), forcing the sdxc to dismount.

Once the folders are synced, the dismounts only occur occasionally.

On a wider note, there is significant performance degradation when using the sdxc card. More than expected. Outlook loads and reacts slower as do any other apps that have large data files sitting on the sdxc. I had to shift browser profiles to the main SSD as performance is severely degraded. This is not normal.
 
I use a 64GB card in my tablet, but I only have music stored on it so it's not a problem. I use my tablet to download photos from sporting events on the day, but I edit the photos on my laptop. I delete any and all photos from my tablet once I get home.

I do have a problem when I plug in a 2TB usb but there is no problem when I plug in a 2TB external HDD (unpowered). In fact, anything I want to save on the tablet gets saved to the external HDD, and I add/delete to any file from there.

So, rather than whine that this won't load or this won't do what I want it to, I found a way around any possible problem.
 
Search tags for this page

azs

micro sd keeps crashing on windows 10 mobile
sd card keeps unmounting in mobile
sd storage class controller

sd storage class controller code 43

sd storage class controller driver win 10

sd storage class controller error
sd storage class controller has a driver problem
surface go sd card error
transcend micro sd card 128gb properties

Members online

No members online now.
Top