What's new

128GB MicroSD card keeps unmounting/crashing

mkenny28

New Member
I have tried 3 separate 128GB MicroSD cards (Samsung, Sandisk, Lexar) and they all eventually just disappear. Usually it occurs after waking up the tablet but it also happens while writing to the cards. It looks like it might be a driver crash because when I look at device manager after noticing the card has disappeared it shows one of the SD Class Storage Controllers as a problem device. Before anyone asks I have done the following with each card:
Formatted each card multiple times to exFat and NTFS and tested each for multiple days
Tested each card in several other devices including my Yoga 2 Pro with no repeating behavior by the cards
Done a complete factory reset of my Surface
All Windows Updates have been done
Downloaded and reinstalled all drivers
Placed tape on SD cards in case it was a loose connection (If it were a loose connection I would hear it unmount)
Set properties on all the cards for Better perfomance

Anyone else having issues with MicroSD cards?
 

LsRamAir

New Member
64GB Samsung card been in mine, NTFS, for over a week straight. Lots of writing and usage. Survived update to win10 and plenty of hard resets and driver toying. Drive letter D: to.

I don't see why it would change for the worse just being a 128, so I'm also thinking some kind of hardware problem.

Try a smaller card for the heck of it??
 

DLCPhoto

Member
OK, I've been seeing this as well with a Lexar 633x 128gb MicroSD card, and have been trying to track down what triggers it. Have made some progress.

In my situation, if I plug in another USB 3.0 device (for example, a Transcend Card Reader, or a Seagate Expansion external HD), most of the time (not 100% for some reason), after the new device is recognized and mounted, within a few seconds the MicroSD card disappears.

Other times, if I run a program (Synchromaster) to copy files from my C: drive to the MicroSD drive, it will start, but then will drop out again.

When I check this drive I find this error in Device Manager:

SD Storage Class Controller
Windows has stopped this device because it has reported problems (Code 43)

I attempted to update the driver, but it comes back stating that the most current driver is installed.

I have checked in Administrative Events, and found variou error messages, the shortest of which is:

The driver detected a controller error on \Device\Harddisk1\D4 (or other Dx numbers)

I can work around the problem by just pushing in on the MicroSD to release it (a Windows recognition sound is heard), push it back in (again a Windows recognition sound is heard), and the MicroSD is remounted, and seems to function fine. But it can drop out again without warning during file copy, so this is not a viable work around.

I tested this with a Sandisk 64gb MicroSD card I have from an Android Tablet, and couldn't get it to dismount with the same maneuvers as above.

So I don't know whether it is this particular Lexar card, my individual Lexar card, 128gb MicroSD cards in general, or what. This card is a fairly advanced card (UHS-1/U3), 633x, so maybe that's the problem.

I just tried to let Windows scan and repair the Card, but it dropped out before it could be done (with nothing plugged into the USB port of the S3).

I'll contact Lexar and see if they have anything to offer (doubtful), and then likely try other cards to find one that is stable.
 

DLCPhoto

Member
There seems to be a pattern with faulty Lexar cards, not just on this forum.
That's the thing, though - I've seen posts in a variety of places, with a variety of devices, where a Sandisk card has problems, while a Lexar doesn't, and vice-versa. It's almost like these high capacity, high speed cards aren't quite ready for prime time.

Best Buy has a Sandisk Ultra 128gb, Class 10 card for $90 - will pick that up when they open, and see if it is more stable.

This is the only significant glitch I've run into with my week-old Surface 3; it has met or exceeded my expectations in virtually every other respect so far.
 

leeshor

Well-Known Member
Sandisk had a problem quite some time ago with a large batch of bad microSD cards. But that was a long time ago and there shouldn't be any still in the system at retail. I haven't seen complaints from Samsung SD cards
 

DLCPhoto

Member
Sandisk had a problem quite some time ago with a large batch of bad microSD cards. But that was a long time ago and there shouldn't be any still in the system at retail. I haven't seen complaints from Samsung SD cards
I've used Sandisk pretty consistently for years, and haven't had problems. Then again, my wife has 2 16gb Lexar CF cards for her DSLR and these have performed perfectly.

I tend to think that these high capacity MicroSD cards are just a bit more finicky than CF or even conventional SD.

Regardless, I just ordered it at my local Best Buy, which had it in stock. They open in an hour, so will go and pick it up. Interestingly, BB price was decent. One 3rd party seller on Amazon $10 cheaper, but BB won't match anything but Amazon, LLC. Plus, I want it now, and easy local return is nice if it craps out on me!
 

DLCPhoto

Member
Just got back from Best Buy, and put the 128gb Ultra Class 10 UHS-I MicroSD into the Surface 3. Was immediately recognized.

Initial testing good. I ran the same operations, connecting/disconnecting the External HD, the Card Reader, ran the same programs as before to move files to and from the drive, and the card never dismounted. Cautiously optimistic.

I'm now loading the card up with movies, music, photos (about 40gb worth) to see if that load changes anything. Will report back later on once that completes.

I contacted Lexar through their online chat, but while he was prompt and courteous, said this was above his head. He suggested I email support directly (support@lexar.com). I may do that out of curiosity, but hopefully the Sandisk will prove stable, and I'll just return the Lexar card.
 
Search tags for this page

azs

micro sd keeps crashing on windows 10 mobile
sd card keeps unmounting in mobile
sd storage class controller

sd storage class controller code 43

sd storage class controller driver win 10

sd storage class controller error
sd storage class controller has a driver problem
surface go sd card error
transcend micro sd card 128gb properties

Members online

No members online now.
Top