What's new

2 rather odd problems

Firipu

New Member
Hello,

Been lurking these forums for quite some time. Finally bought myself a surface pro (goddamn late release date in Japan)

Absolutely loving the device, it's everything I always wanted.

But I have 2 small problems

1) My stylus doesn't work in the upper left corner. There's a spot of about 1cmx1cm big where I cannot use my stylus. It doesn't recognise it. e.g. I can't change profiles in google chrome with my stylus. It works perfectly with my finger though. I have tried to recalibrate my pen, but the spot remains. Is that a common problem? Or would I have a faulty unit?

2) Today I was using my surface in the train when all of a sudden everything Metro UI related became all buggy. Nothing but artifacts, completely unusable. After a while the whole PC just crashed. I had to do a hard reboot to get everything back to normal. This happened twice on a charge. Hasn't happened since, but I haven't used my surface that much, only have had it for 2 days now... All the latest updates are installed.
I tried to take a screenshot to show it, but the screenshot failed as well :(

Should I try to get my unit replaced? (especially the deadzone bugs me, the weird crash doesn't bother me that much, it's windows after all) Or does everyone have that problem?

Thanks a lot,

Firipu

edit: One more small thing, does anyone manage to scroll with the stylus? Absolutely impossible in Metro apps for me. Now matter how much I flick, no matter how much I change and fiddle around with the settings.
 
OP
F

Firipu

New Member
mhm, great start of my first post ever, I just fixed problem n1. I reset all my calibration data, and recalibrated again, this solved the unworking spot in the upper corner. Pfew :)
 

Members online

Top