What's new

Solved Another day, another issue. App store


Active Member
Ok here I go.. I am starting to think that the SP3 and I can't live in harmony.

Today my app store appears busted as I can't download anything. I get error code: Ox80240440

I can't download apps I've paid for and I even tried other free apps. No dice!

I searched this error code and have tried everything under the sun. I ran a code to refresh the App store, I downloaded a MS program to fix the App store and same olé same olé failure.

Fed up, I reset the SP3 and installed as new figuring this would solve the issue. Nope! Even after a complete reset I am still getting the error.

Oddly enough, I can download apps on my Windows phone, using the exact same account just fine.

I love the SP3 but these quirks are getting maddening..

Any other suggestions before I bounce it off the wall?

Screenshot: This is of a paid app that I own. I get same error message even on free apps

Screenshot (1).png
Make sure your time zone and time settings are set correctly, another issue to look at is Antivirus or other Security Software. Or is your router blocking some of the infomation needed.
Thanks for the response. One of the suggestions I found and tried on the net was the time zone suggestion. Mine was correct but I reset it just to be sure.

I am only running Windows Defender.

I am resetting the router now but my phone was also connected to the same WiFi and it can download from the Windows phone store just fine.

I am also resetting the SP3 again as the previous reset went rather fast. This time is going nice and slow. Perhaps the previous reset left something in tact.

Will report back once the SP3 has reset and the router has also been factory reset.
Nope.. No dice!

I surrender to the PC gods, in the box and back to MS it shall go. Bummer because I really liked it. :/
It sounds like something is afoot with your Microsoft Account....do you have access to another Windows 8.x machine (not Phone as it has a seperate account backend)
No I only have a Windows 7 machine. I called MS and the rep wasn't very helpful. I had just completed the reset and be basically said he could not help until I ran all the updates.

I said fine can you call me back in a few hours and he said he was booked up until Tuesday and could call me back then. I said no thanks and hung up.
I decided to call MS again in a last ditch effort. After a brief 2 hour hold (seriously MS?) a rather rude rep picks up the line (lucky me) I tell my story of woe and he says it's a known issue that a lot of people are having and they are working on it. I find this odd since not a single other member of this forum has complained of the issue.

I asked him to see if everything in my Microsoft account was okay and he said he would need to transfer me to Store support. I told him I had already been on hold for 2 hours and he said it will probably be another 2 hour wait for a store rep...


I asked if there was anything else he could do and he said no and again stated its a known issue with many others having the same problem..

I have started a return and printed the shipping label. I guess if it's not magically working in the morning then I will factory reset it, box it up and ship it back on Monday..

This is the screen I am now welcomed by in the store

Screenshot (2).png
Last edited:
Man, it sounds like your sp3 is snake bit. I had the same problem on my sp2, but going back to a restore point took care of it.
The store is back working, magically! So that's cool.

I guess it must have been an issue on MS end.

I do have a lingering issue that I noticed yesterday when doing my reset song and dance.

I had a Yoga 3 Pro and I thought it may have been an issue with that because when I restored my SP3 it downloaded all the Levono Apps.

I went to OneDrive to delete my device backups but I was getting an error page. With the store working this morning it thought i'd try again. Still getting the error page.

I go here: https://onedrive.live.com/Options/DeviceBackups and I am still getting an error page.

Screenshot (3).png

One last odd thing going down is that when I choose a full wipe during factory reset it restores all my apps and their position on the start page. I am never given the choice to restore from backup or set up as new.

I do recovery --> remove everything and reinstall windows --> fully clean the drive

I don't get a clean out of the box type install because everything on start screen stays per my pre wipe setup.

Not sure if these other 2 problems ate related to the store issue. But since the store is back working I am a happy camper.