What's new

anyone using SP successful on Verizon FIOS?

mtalinm

Active Member
my SP stopped connecting to my home wifi roughly 10 days ago. I called Surface Support and they said it was because I was using WEP encryption, so I switched it to WPA2 as requested. no luck. refreshed and reset the Surface pro. no luck. got fresh N router from Verizon. no luck. got tonight's firmware update. no luck.

anyone successfully using the SP w/ Verizon FIOS?
 

bosamar

Well-Known Member
I've had Verizon FioS since 2006 here in SoCal. Never had any connection problems across multiple smartphones, tablets, laptops, and desktops. If you are new to FioS check for a firmware update on your router. Calling FioS tech support won't hurt. We currently have 75 Mbps up / 35 Mbps down.
 

HD_Dude

New Member
I have FIOS too, 75/35, like Bosamar.

No problems at all with the Surface Pro.

The 2-year old stock Verizon router, which is not an 'N' model, works fine with the SP and everything else I have pulling internet.

Have you done some overall trouble shooting?

First, can the Surface see your WiFi signal, but can't connect? Or can it not see it at all? I've had trouble connecting with other gear when I hide my SSID. Is it hidden? Or displayed? If hidden, try displaying it.

Then, if I were in your shoes, I'd take the Surface and try a bunch of other WiFi...Starbucks, McDonald's, even the hotspot on a smartphone, and see if you can get online using those connections.

Also, at home, I'd crank up other devices, like a laptop, and see whether they can get on using your FIOS WiFi.

These steps obviously meant to drill down and identify exactly what the problem is: your Surface; your network; or the way they communicate with each other.

If everything works perfectly, except for the Surface on your home network, let us know.

Good luck.
 

qi88

New Member
This is just a wild shot but maybe go to the Network and Sharing Center on the Surface Pro (right click on your connection in the system tray) and then look for Manage Wireless Networks on the left. Delete all of them -- hopefully, your wireless is one of them. Restart the Surface Pro and then connect from scratch.
 
OP
M

mtalinm

Active Member
thanks all ... had tried all of this stuff and even replaced the router to no avail.

today I pled my case at the local Microsoft Store and they swapped me straight across for a fresh SP! works great now.
 

machistmo

Active Member
thanks all ... had tried all of this stuff and even replaced the router to no avail.

today I pled my case at the local Microsoft Store and they swapped me straight across for a fresh SP! works great now.
I would wager the firewall was the issue the entire time. Glad to hear they stepped up and replaced the device.
 
Search tags for this page
fios app for surface pro 3

fios app for surface rt

fios mobile app for surface

fios mobile for surface

fiosand surface pro3
surface pro 3 verizon fios

surface rt fios app

verizon fios app for microsoft surface
verizon fios app for surface pro
verizon fios on ms surface

Members online

No members online now.
Top