What's new

AverMedia DVD EZMaker 7 issues

MisledYouthUK

New Member
Has anybody tried to use one of the AverMedia DVD EZMaker 7 USB capture sticks with their Surface Pro 2? I'm having problems getting it to detect it.
I got the most up to date driver I could find online, the 10.2.x.103 for it from here as the CD provided only covers Win 7. My system seems to recognise that it's installed OK in device manager and updating it just confirms I have the most current version.



When I plug it in to the USB port it doesn't make the "dingle-ding" sound to say it's detected it. Yet when I plug it into any other computer it has no problems and starts installing device driver software so I think the stick itself is working.
Am I missing something extremely basic here or does anyone know of any issues with this kind of device? Their tech support is pretty slow at responding.

Thanks
 

yeewiz

Member
well, I must be missing something here. The SP2 doesn't have a DVD so what are you trying to do with this device? I was drawn to this post because I do use the Avermedia TV stick.

UPDATE: never mind, read the reviews. Looks like some people have problems with the install and the software. Good luck!
 
Last edited:

Ruffles

Active Member
Could it be that the device is drawing too much power thru the USB port? I've experienced what you describe with some USB hard drive enclosures. Have you tried connecting it thru a powered USB hub?
 
OP
M

MisledYouthUK

New Member
Thanks Ruffles. OK I got a fix on it. The version of the cyberlink software that comes on the CD with the USB dongle is not compatible with Win 8.1. I got a reply from Avermedia's help team (who can be contacted here) and they gave me a link and login to download cyberlink media suite 10. It now detects the camcorder and I can capture the footage.

However......

I'm getting some kind of interference on the footage when viewing it in the capture software. The picture can be clear in parts but then start to shake and distort. It does it all the time but mainly when the footage was shot in a moving environment. What's weird is that when I look down the eyepiece of the camcorder it doesn't do it at all and it was not a problem when I put the footage, on to VHS a few years back. It's completely clean there. Has anyone encountered this issue?
 
Search tags for this page
avermedia dvd ezmaker 7 power director

avermedia dvd ezmaker 7 troubleshooting

avermedia dvd maker 7 windows 10 not working

can you use the avermedia with a windows surface

download software cyberlink ezmaker7
dvd ezmaker 7 windows7
ezmaker 7 does not detect device
ezmaker 7 problem
ezmaker dvd usb dongle not recognized
how to install aver media dvd ezmaker 7 to windows 10
Top