What's new

Crashing when Reattaching Clipboard to Keyboard Base

ABswl13

Member
Lately, I've been having a specific issue with reattaching the "clipboard" back into the keyboard base. In particular, while using my Surface Book as a "clipboard," upon reattaching it to the base, the screen goes black and the Surface Book becomes unresponsive. I'm then forced to do a hard reboot to get it working again. This happens randomly.

Has anyone had this problem? Is this a display driver issue or hardware issue?

Thanks.
 

sharpuser

Super Moderator
Staff member
I had this once, but became convinced that Windows was doing an update while I was reattaching the Clipboard. So a day or so later while detached, I did a Defender update, and quickly re-attached while it was being applied. Got the error again.

Your issue may also be due to changing the hardware connections while Windows is updating. Seems to be something Windows can't handle well. Next time it happens, check your update history.
 

Orlbuckeye

Active Member
I know if you have dGPU set as your default and you have apps open the SB will force you to close the apps before detaching. I'm not sure about if you attaching. It could be the issue with the Intel driver for the integrated GPU. Did you download the new Beta Intel drivers for the GPU?
 

Astonish

Member
I have a Surface Book since 4 days. It has worked flawlessly with a real good battery. I have the i7 dGpu version. Today the same thing happened to me for the first time. I was using the clipboard on the base folded on the keyboard. After I finished my drawings, wanted to turn off the computer, so I detached it and then reattached to the correct position to shut down and close the lid and suddenly the screen went black. I could hear that the computer was still running as I tried detaching and reattaching several times, I could hear the notifications but the screen was all black. I tired holding power button briefly, nothing happened, tried holding it 15 seconds, again nothing happened. At the end I had to hold the power and volume up button for it to restart. I did not have any software running when I tried to reattach, I always close all the softwares before doing it.
 

Seneleron

Active Member
I did a Defender update, and quickly re-attached while it was being applied. Got the error again.
I'm going to have to see if I can duplicate this now. Granted, it's my own fault for jinxing myself by publicly commenting on how stable my SB has been, but I've gotten this issue a few times over the weekend [once while actively playing a youtube video. Screen went black, audio kept right on playing.

I'd NEVER see this at home, but with 56k era hotel bandwidth, might just explain it...
 
Search tags for this page

display goes black on surface with keyboard attached

ms surface book power when attaching clipboard

my surface book will goes to sleep once attached to the keyboard

restart hangs after surface book screen attach and reattach

sirface book goes black when attached tk keyboard

surface book black screen after attached

surface book black screen after attaching clipboard

surface book boot

surface book reattach error

surface screen goes black when connected tokeyboard

Members online

No members online now.
Top