What's new

Docking station not working

Hi All,

I own both a Surface Pro 3 and a Surface Pro 4 and als the 'brick' type docking station.
The problem is that the docking station works flawless on the Pro 3 but not on the Pro 4.
I tried 'everything' form resetting the surface pro 4 itself, installing Win 10 freshly, etc
I also updated the firmware on the pro 4. Also tried to update the firmware on the docking station with the microsoft dock update tool but this tool gives an error saying "no docking station attached'
Running the same tool on the Pro 3 works fine and I updated the latest firmware on the docking station using the pro3. I thought that after this docking firmware update the problem would be solved. No luck; connecting the dock (after the update) to the pro4 --> no luck; no ports detected on the dock using the pro4 while everyting works very well on the pro3. So the problem must be the pro4 itself. By the way: it does charge the pro4.
Another symptom is that when I connect a USB flash drive to the USB port of the dock, the LED of the flash drive blinks once, then 3 to 4 seconds the LED is off and after that the LED blinks very fast continuously.
As a last attempt, I was lucky to borrow another dock (also the 'brick' model) from a friend and still the same: all well on the pro3 but nothing on the pro4.

I hope someone can help. It drives me crazy.....
 

sharpuser

Super Moderator
Staff member
I suspect your port on the Surface Pro4. Make sure it is clean and free of debris.

I’ve mentioned many times on this forum how a metallic filament somehow was attracted into my Surface Book 2 port, as it is magnetized. Gave me fits for 9 weeks.

Get a cup of coffee, bright light, isopropyl alcohol, a handkerchief, and a cotton swab. Cover the port with the handkerchief and blow through the cloth into the port. Swab and inspect with the light. Repeat.

If the port connector is reversible, try both ways.

Drink the coffee. Might take awhile.

Let us know.
 
Search tags for this page

surface docking station mouse and keyboard not working

Top