What's new

External Monitor Screen Flicker

scfoster

Member
Brand new Surface Pro 3 connecting to Apple MC007LL/A 27 inch LED Cinema Display which has a MiniDisplay Port connector.
There is an intermittent screen flicker (no particular apps running). From time to time the screen goes black for about a second, then comes back.
The resolution is 2560 x 1440 which is "recommended".
I use this screen all the time with the Macbook air with no screen flicker, so I doubt it's the cable connector.
Any ideas?
 
OP
scfoster

scfoster

Member
Called MS Support and they had me uninstall the drivers, reboot then hook up the monitor (which re-installed the driver).

If it does flicker it's hardly noticeable if at all. So I think it's fixed (hopefully).
 
OP
scfoster

scfoster

Member
The refresh rate was at 59Hz so I set it to 60Hz. The monitor went berserk with even the internal monitor speakers emitting a scratching sound.

Reverted back to 59Hz, no joy. Back to 60Hz... still going wild. Unplug monitor then replug in... better. Apply 60Hz again, save changes and it seems to settle down.

However there was a slight flicker while I was typing this. Just one time. We'll see. Thanks for the tip.
 
OP
scfoster

scfoster

Member
Well that didn't work..... had to unplug and re-plug it in.

I hate to say it but I'm moving into the "return this thing to Microsoft" and go back to the Mac. It's supposed to be a tool, not a project. Big difference.
 

BobC

New Member
I had this problem with the original Surface Pro. Tried all the refresh adjustments, reloaded the drivers, adjusted screen resolution. Nothing helped. I have the Surface connected to a Dell S2240T. Here's what the problem was. I had bought an adapter cord on Amazon - trying to save $ because the Microsoft product was about 10x more expensive. The end plugging into the Surface had a square face while the Surface edge face is slanted. That meant the adapter cord could not totally seat. Finally sprang for the Microsoft product. It has a slanted face that matches the angle of the Surface perfectly. Since then NO more flickering or momentary blackouts.
 
OP
scfoster

scfoster

Member
thanks for the info... however the monitor connector worked just fine with the Surface Pro 2. As with the SP3 the connector is long enough that when fully seated there is still a gap large enough to fit the edge of a credit card. There is no interference between the connector shield and the side of the SP3. So I doubt that's the issue.
 

Seneleron

Active Member
Completely won't help you, but I don't have that issue with my SP3 and my 27" Apple cinema display. I *DID* have that problem with my desktop and my dell 2913WM. A new cable fixed it. In your case, unfortunately, that's not an option...
 
OP
scfoster

scfoster

Member
Completely won't help you, but I don't have that issue with my SP3 and my 27" Apple cinema display. I *DID* have that problem with my desktop and my dell 2913WM. A new cable fixed it. In your case, unfortunately, that's not an option...

Actually that totally helps me as I now know others can use the 27" Apple LED Cinema display without the screen flicker.... so thanks for the info.

I have to return the other SP3 to the Microsoft Store (long story). So we'll see if they have a monitor that I can plug into to test the connection. I'll also pick up a cable to eliminate that variable.

I've tested both SP3s with the monitor and get the flicker. However the SP2 has never had an issue, nor does the Macbook Air.
 

GoodBytes

Well-Known Member
Can you make sure that the Surface Pro 3 Windows power plan is set to High Performance, and plugged in. Does that help?

What you are describing is something I can replicate very closely to what you are saying by forcing a downclock of my laptop Nvidia GPU to minimum speed, where the graphic solution has now trouble syncing the refresh rate of both monitors. The GPU isn't fast enough to sync both together, so the desktop monitor flicker. Normally, Nvidia graphics card clock faster (not sure about the GeFroce 600 series and up), when you dual screen. in fact, it looses all power saving features related the GPU specifically in multiple monitor setup.

I am thinking that something similar is happening on the Surface Pro 3, where the Inlet GPU isn't fast enough, of the GPU clock keeps changing on the fly, via too aggressive power saving rules set by either Intel or Microsoft.

All I can say is try Intel drivers for the graphics solution. Be sure to download the .zip file of the drivers, extract them, uninstall the current one via Device Manager, restart, and in Device Manager again, this time install the drivers, and tell Windows to use the extracted files. Once done restart your system one more time.
 
Last edited:
OP
scfoster

scfoster

Member
Can you make sure that the Surface Pro 3 Windows power plan is set to High Performance, and plugged in. Does that help?

What you are describing is something I can replicate very closely to what you are saying by forcing a downclock of my laptop Nvidia GPU to minimum speed, where the graphic solution has now trouble syncing the refresh rate of both monitors. The GPU isn't fast enough to sync both together, so the desktop monitor flicker. Normally, Nvidia graphics card clock faster (not sure about the GeFroce 600 series and up), when you dual screen. in fact, it looses all power saving features related the GPU specifically in multiple monitor setup.

I am thinking that something similar is happening on the Surface Pro 3, where the Inlet GPU isn't fast enough, of the GPU clock keeps changing on the fly, via too aggressive power saving rules set by either Intel or Microsoft.

All I can say is try Intel drivers for the graphics solution. Be sure to download the .zip file of the drivers, extract them, uninstall the current one via Device Manager, restart, and in Device Manager again, this time install the drivers, and tell Windows to use the extracted files. Once done restart your system one more time.

There does not appear to be a "high performance" setting. The only setting offered is "balanced'. Within the "balanced" plan, there are no options available to increase video performance.

Also, I'm not running dual monitors yet still get the flicker. I'm only using the Apple LED Cinema display (SP3 display is dark) yet still have the issue. The current resolution on the LED Cinema Display is the native resolution and was the same one I used with the SP2 with no issues.

From the help file:

The only power plan that Windows provides for PCs with InstantGo is Balanced. This plan offers full performance when you need it and saves power when you don't. You can customize this further to meet your needs or create your own plan (using Balanced as a starting point). Your PC manufacturer might also provide additional power plans.

We are RAPIDLY approaching the point of returning for a refund.
 
Last edited:

GoodBytes

Well-Known Member
Oh shit, it is true! Damn! I forgot. Sorry
Well try Intel drivers if you haven't.

If still no fix, I don't know at the moment.

But, if you have a moment, can you test me this:
Try, (again just for testing purposes, and not suggesting a solution, as it isn't, I know), to reduce the resolution of your nice Apple Display to the lowest you can. Does the flickering still happen?
 
Last edited:

Staff online

Members online

Top