What's new

Extreme Video Playback Lag

Spl33nMaster

New Member
Recently my Surface 2 has suddenly become extremely laggy when playing videos. A few days ago, I could play a regular movie with no issues, but now I can't even play a youtube video without extreme lag with the video (the audio plays perfectly however). If I make the video fullscreen, the framerate drops to about 1 frame every 2-3 seconds and the tablet becomes very very hot.

Can anyone help me?
 

beman39

New Member
that shouldn't be happening, maybe try looking in your device manager to see if you have any failures by seeing if you have exclamation marks beside the device...also look in your event viewer and see what is/if anything is crashing, you can get in there by long press the windows logo on the bottom left and a menu will pop up and there you will find the event viewer. should tell you what's going on.
 

Hstakz

Member
Recently my Surface 2 has suddenly become extremely laggy when playing videos. A few days ago, I could play a regular movie with no issues, but now I can't even play a youtube video without extreme lag with the video (the audio plays perfectly however). If I make the video fullscreen, the framerate drops to about 1 frame every 2-3 seconds and the tablet becomes very very hot.

Can anyone help me?
Exact same with me buddy. There is another thread active with people with the same problem. My guess is it's google under going maintenance after the new comment update for YouTube. It's incredibly frustrating but for a temporary fix, I reset IE.

It doesn't wipe your favourites or anything but only cached websites.

1. Top right corner hit the settings icon under the 'X'
2. Internet options
3. Advanced tab
4. Down at the bottom is reset

It helps a little, im now able to watch a least a couple of videos before it doesn't respond. Anyway good luck with that!
 

king182

New Member
that shouldn't be happening, maybe try looking in your device manager to see if you have any failures by seeing if you have exclamation marks beside the device...also look in your event viewer and see what is/if anything is crashing, you can get in there by long press the windows logo on the bottom left and a menu will pop up and there you will find the event viewer. should tell you what's going on.
On my device nothing is happening when I press the windows button for a long time - I just return to the start screen...mhm?
 
OP
S

Spl33nMaster

New Member
that shouldn't be happening, maybe try looking in your device manager to see if you have any failures by seeing if you have exclamation marks beside the device...also look in your event viewer and see what is/if anything is crashing, you can get in there by long press the windows logo on the bottom left and a menu will pop up and there you will find the event viewer. should tell you what's going on.

No exclamation marks on anything in Device Manager, and there's nothing critical or important showing up in event viewer (there have been about 188 warnings though in the past 7 days).

And it's super laggy for streamed and local video playback. :/ I'll try a refresh and see if that fixes it. I don't want to have to return this, because this is my 2nd surface already. The first one blue screened constantly, and bsod'ed 3 times during a system reset, :/
 
Search tags for this page

how to fix lag video on a surface rt

how to fix youtube lag on microsoft surface
microsoft edge youtube lag

microsoft surface lags streaming videos

surface 2 lag while streaming

surface 2 video lag

surface 2 youtube fullscreen lag
surface rt laggy video

surface rt video lag

videos lag on my microsoft surface

Members online

Top