What's new

Firmware update filed today.

G-man

Member
I checked for updates today, and there was a Firmware updated listed.

I told the system to install. All seemed to go okay, but when I look at the update history I see:

System Firmware Update - 12/10/2013
Failed to install on 12/10/2013

This update failed to install on 12/10/2013 at 4:01 PM with error code 80070490

But when I check for updates now, there are none.

Can someone look in device manager, Firmware, and see what version driver is listed for:

Surface Pro System Aggregator Firmware ??
 
OP
G-man

G-man

Member
Tech told me the Firmware update was pulled because of a bug and will be re-offered on 12/12/2013.

Strange.
 

Dim-Ize

Active Member
Tech told me the Firmware update was pulled because of a bug and will be re-offered on 12/12/2013.

Strange.
I have the same issue. Glad to know it will be re-published. Hope all the fixes with the dsim.exe from elevated command prompt wont interfere. Thanks for heads up.
 
The 10th December update is showing as available for me, but I'm hesitant to try it now...

Seems odd that it would show up after being pulled; perhaps it's fixed and reinstated?
 

tech57

New Member
I allowed the update to download and install on my SP2.
A behavior change is the light at end of the power cord goes out when the battery is fully charged.
I removed the charging cord (battery fully charged) and observed at initial connection the light was on but shortly there after the light went out. I assume the software recognized a fully charged battery.
Anyone else notice this?
 
OP
G-man

G-man

Member
I did a full factory wipe and restore last night. Now I have the dreaded unknown device in Device Manager for the Surface Cover Telemetry.

I see the FW update too, so I think the tech on chat with me was mistaken, or just trying to get ride of me :D
 

DragonGamer

New Member
I see the FW update too, so I think the tech on chat with me was mistaken, or just trying to get ride of me :D
No, I rather think MS had one of its rare occasions where it was faster than expected :D
Today morning the update failed for me too but just right now I rechecked for updates and got a new firmware update under exactly the same name (Systemfirmwareupdate - 10.12.2013) and this one installed without problems :)
 

Ruffles

Active Member
I did the updates last night. They took a LONG time to install - particularly update 14. I was getting worried. Once completed, I checked the history and 2 of them failed but the firmware updated succeeded. I re-applied the ones that failed and they worked the second time.
 
OP
G-man

G-man

Member
I allowed the update to download and install on my SP2.
A behavior change is the light at end of the power cord goes out when the battery is fully charged.
I removed the charging cord (battery fully charged) and observed at initial connection the light was on but shortly there after the light went out. I assume the software recognized a fully charged battery.
Anyone else notice this?
My light never goes out, even fully charged.
 

kristalsoldier

Well-Known Member
I allowed the update to download and install on my SP2.
A behavior change is the light at end of the power cord goes out when the battery is fully charged.
I removed the charging cord (battery fully charged) and observed at initial connection the light was on but shortly there after the light went out. I assume the software recognized a fully charged battery.
Anyone else notice this?
Can't say I noticed it either. I'll try to keep a track of this next time.

I am tempted to say that there has been a bit of a battery improvement too - I took the Surface 2 off the charger at 10AM. Reached my place of work at 10:15; Started working on a document at 10:30. It's now 7:30PM and the battery icon shows 53%. Brightness at 40%; WiFi and BT on all the time; average workload: One Office document, IE11 open with 3 tabs; SkyDrive Open; Mail app open with 3 accounts (1 account checking mail all the time - 1 account checking mail every 15 minutes - 1 account checking mail every 30 minutes).

I'd say that I could easily get another 2 hours of work done (exactly as mentioned above) till the battery goes below 20%. That would mean about 11 hours of steady work which, I think, is damn good! Before the update, I was getting IIRC about 9 hours with a similar load.
 
Search tags for this page

0x8024ce0a

0x8024ce33
error 0x8024ce0a
how to revert a system update on surface pro 2
latest surface firmware stuck on getting devices ready 20%
rt systemfirmwareupdate - ‎10.‎12.‎2013
surface cover telemetry code 28
surface pro 12/10/2013 firmware update
surface pro system aggregator firmware long time
surface pro telemetry firmware

Members online

Top